dangerous bug with "Render" in WL Pro 9.5.1

The situation: I tried the new WL restoration functions with a mono file, then reset the Master Section, closed the mono file,
then I loaded a stereo file and checked out the Mastering Rig, hit render -> the result: a mono file!
Unbelieveable! Then I checked it with another plug in and got everytime a mono file.
After the restart of WL rendering was fine with the same file and same Master Rig setting. This is a very hazardous bug IMO, because it can lead to accidently monofied stereo files if not checked again (which should be good practice of course). The preview is always stereo - only the rendering was affected.
Please fix this one ASAP.
macOS El Capitan …

Is the render file actually mono? Doing the same thing here, I get stuck with mono metering and mono monitor until restart, which is still a bad problem, but the render file is actually stereo.

Yes, I got a mono file! Monitoring was fine - if you mean playback thru Mastering Rig and plug in as a ‘preview’. As I mentioned, mono file (that means L+R was present but was mono in a stereo file!) was only a rendering result. I tried it with a selected range and the whole file - always mono!
Please check if your file contains stereo data.

I mean I didn’t get stuck with the mono metering and mono monitor until after the second render (the render through the Master Rig). I could audition and meter stereo through Master Rig before the render, but when I did the render and played it back, it was like the output was stuck in mono metering and mono playback monitor that I couldn’t get out of. But when I restarted and played back that render file, it was a stereo render file.

that’s what i got anyway.

Ahh … that could well be. I didn’t save the file, just playing back, because I was checking out the new functions. Thank you for the additional tests.

You don’t even need to use any plugins. Just play a mono file. Then play and render a stereo file using wav default and “bypass master section on result”. Then play the render. The output and metering will be mono.

It will switch to stereo playback if you turn off the master section bypass button on the rendered file.

Thanks for the report. This will be fixed in next patch.