Dashed Barlines

I’m having problems with dashed barlines. As an example, I’m copying the first few bars of Bartok’s “Music for Strings, Percussion and Celesta” where he uses dashed barlines to show the subdivisions of 8/8, 12/8, etc. They should only show up in individual parts, but they extend between all parts, just like the regular barlines. Worse yet, the bar numbering sees them as separate bars, so the number for bar 3 shows up as 8 (which would be correct if the dashed lines denoted separate bars). Is there some way to restrict the dashed barlines to one particular part, and count only the normal barlines?

Chet

Yes, absolutely! You need to create an aggregate time signature, e.g. type 8/8|12/8 into the Shift+M popover, and you’ll get a time signature that counts only the normal barlines with automatic dashed barlines between the different rhythmic groupings.

Thank you Daniel! However, for this particular piece, there is a different time signature in each of the first 16 bars alone (and there are 88 bars total, most of which change time signature). It seems to me that for something like this, it would make more sense to turn bar numbers off, and enter them manually. It would be a pain, but less of one than trying to enter a composite of more than 70 signatures.

My other question concerned dashed barlines, which Bartok uses only for entries of the theme, so they only ever appear in a single instrument, while the other instruments play the normal accents implied by the time signature (and note groupings in signatures such as 7/8). Do I take it that dashed barlines cannot be restricted to a single instrument?

Chet

P.S. Just out of curiosity I exported this to Sibelius 7.5 via Music XML. Sibelius read each dashed barline as one bar as well, but it substituted normal barlines for them AND added a time signature to EVERY bar. Thus, it begins with three bars of 8/8 rather than just one with two dashed barlines. (Those bars consists of 3, 3, and 2 beats.) Of course, you can change each normal barline to dashed ones (one at a time) and each time remove the extra time signature and tell the dialogue box not to rebar. And the dashed barlines still span all of the instruments.

I couldn’t resist re-importing this file back into Dorico, and got exactly the same result as in Sibelius.I suppose it’s the limitation of Music XML. I’ll go look for the spec for Music XML now.

They can, though beware that this is a bit experimental. Make sure nothing is selected in the music, click the dashed barline in the Barlines panel, then hold Alt as you click on the note before which you want the barline to appear. That should do it.

That didn’t work for me. Maybe because I’m on a Mac? (Also on Yosemite, which I know I should upgrade.) I tried Alt/Option, Command, and even Control with no luck. The first two just gave me the regular dashed barline. Any hope that this will become a feature? Or would I have to use a graphic for this?

Chet

You’re right, at the moment this isn’t possible with barlines specifically, though it is possible for time signatures, so you can achieve the results you need by creating a time signature by holding the Alt key, which will create it only on the staff on which you clicked, then hide the time signature if necessary via Properties, then put in the dashed barline with Alt. All of this might be a lot more trouble than it is worth, however.

Yeah, it would result in a bunch of time signatures in each bar and wouldn’t allow for the real time signature, so yes it’s more trouble than it’s worth and it also doesn’t recreate the look of the music. I guess it’s not possible to recreate this score. Oh well. :frowning:

In case anyone is wondering what this is all about, I’ll attach the first page of the work so you can see.

Chet
Bartok - MSPC p1.jpg