DCOM connection to program 'Synsopos.exe' failed.

I tried uninstalling the Halion Sonic program when the trial expired and I kept getting error messages that many sound files were not found. This happened when Cubase 6 booted up. So I tried reinstalling Cubase and now the installation gets hung up and kicks out the error message “DCOM connection to program ‘Synsopos.exe’ failed.
Error:The server threw an exception.” does anyone know what the solutiion is for this?


Hi Scojo:

I had this problem just the other day. Two of four updates failed for Windows 7 (64 bit) after I had run a registry defrag. (I’ll be more careful about that in the future). If you go to microsoft, and I can’t tell you where now, you can download a kind of “update inspector” or some such that ultimately re-installs what I think are COM and/or DCOM components necessary not only for automatic windows 7 updating but for this link to Synsopos.exe when cubase 6 or wavelab 7 attempt to initiate. After that all was well. Wish I could be more specific, but the two are related in some way.


If you’ve in any way tweaked your Windows Services make sure the service called ‘DCOM Server Process Laucher’ is on Automatic and is running.