DCOM Synsopos.exe error... Cubase 9 wont open

Last time I opened Cubase 9 everything ran perfectly, but after the “Windows 10 Fall Creators Update”, the following error pops:


eLicenser Control - Error
Application ‘Cubase / Cubase Artist’ has caused the following error:

DCOM connection to program ‘Synsopos.exe’ failed.
Error:Unspecified error

What do I do? I tried this, but Windows won´t let me setup a DEP exception for Synsopos.exe
https://www.steinberg.net/forums/viewtopic.php?f=25&t=128126&p=701218#p701218

Windows pops the following error:

"Data Execution Prevention

This program must run with DEP enabled. You cannot turn off DEP for this program"

Gee… thanks microsoft.

This is the kind of thing that forces users to cross over to MacOS. I´ve used Cubase in a Mac computer at work for years and I´ve NEVER seen this bullshit errors that Windows tends to cause

Hi
I did a raw install of Windows 7 and then had to get the automatic updates installed before Cubase 9.5 would run.
The DEP thing is a bum steer i think,
I had exactly the same as you with the error messages.

Best use Windows 7 and install all updates. The DEP made no difference to my pc.

This is a Cubase/ELCC issue and has been around for years. Check google or this forum for that confirmation. Blaming MS is a little too easy.

Try uninstalling ELCC completely, then reinstalling. It’s the only thing that worked for me.

Thanks Fixbin,

Well, I blame MS because after the update a buch of stuff stops working, including but not limited to ELCC.

So yes, I blame MS for not making sure their updates check for compatibility before messing up my computer.

I agree it’s changed the way i have to load up software on my pc as well. Luckily i’ve got it sorted at the moment.

Anyone knows how to bypass this wretched windows update?

I don´t need this “paint 3d” crap or whatever unforgettable, useless junk MS is installing that I won´t ever use.