DeEsser: No effect if Sidechain is disabled with Mon enabled

Here’s a minor bug that can cause some confusion.

  1. Open any project and import an audio track.
  2. Insert the DeEsser plugin.
  3. In the filter section: set LO to “20Hz” and HI to “20kHz”, in order to make the effect as audible as possible.
  4. Click the SIDE CHAIN button to enable the sidechain.
  5. Click the MON button to enable monitoring of the sidechain.
  6. Click the SIDE CHAIN button again to disable sidechain while MON is still enabled.
    -> Result: The DeEsser stops applying any effect, even if you try to change the settings.

Additional notes: This only happens if the LIVE mode is disabled (default setting).

Workaround (for users): Click the SIDE CHAIN button again and disable MON, then disable SIDE CHAIN. The effect will then work as expected.