Default beaming in 2/4

I’m running into a particular situation where Dorico incorrectly beams a measure, and insists on the incorrect beaming no matter what I do. I’d like to report the bug, both to get it fixed and perhaps get a workaround in the meantime. Or maybe I’m doing something wrong.

I’ve uploaded a few measures illustrating the situation. The time signature is 2/4. The first four measures are automatically beamed correctly. The fifth one isn’t. It’s a combination of a 1/6th note, followed by 3 1/8th notes, and ending in a 1/16th note.

Image 8-7-23 at 7.50 PM

Welcome to the forum.

It’s customary to ask whether there are options to control things, rather than to assume that something’s a bug.
In this case, it’s controlled by this Notation Option:


Hi there. Thanks, that did the trick! And thank you so much for getting back to me so soon! Very cool.

Typically, yeah, I do look for options that I may not see right away, before, as you say, assuming there’s a bug. So I certainly agree with you. This case, though, is somewhat exceptional, perhaps, and maybe something for you folks to consider. Earlier, when I started the project, I had found Library < Notation Options. Working down the list of options, I saw “Beam Grouping”. And, indeed, that seemed to be exactly what I was looking for. I’m not sure exactly what settings I chose, but that seemed to do the job. Notice that in the first four example measures I sent you, the syncopation in the middle of the measure is notated perfectly. So if I enter an 1/8th note, Dorico automatically changes it to two tied 1/16th notes. It’s only in that one specific case (1/16 note, three 1/8 notes, a 1/16 note) that Dorico didn’t handle the syncopation “correctly”. So then I returned to Library > Notation Options > Beam Grouping to see if there was anything else I could set, but didn’t find anything.Since I thought I was in the right location, I guess I didn’t keep working my way down to Note Grouping. They are very similar sets of options, and I wonder if combining them into “Beam and Note Grouping” might be better.

btw, I still don’t understand why the first four examples I sent worked as expected. They all have similar middle-of-the-measure syncopations. It was only the fifth example that didn’t work. And, boy, I tried various workarounds. e.g., for the problematic 1/8 note, I tried first entering two 1/16 notes, then manually inserting a tie. The moment I inserted the tie, Dorico converted it into an 1/8 note!

I do want to end by saying, overall, how amazing Dorico is. Very polished and easy to use and navigate. And I really appreciate that I got a response so quickly through the Dorico forum. So, overall, I’m a very satisfied user! Thanks. – Michael

(Irrespective of the notation options and what you might consider correct)
You can always use Force Duration (O) to keep the 1/16th note and tie it to any note duration you’d like.

Hi there. Thanks for the tip! :slight_smile: