Default CC1 value

Is there a way to change the default CC1 value? It always returns to 64, which causes weird “spikes” in playback when starting from pp:

These can be smoothed out manually, but it takes some time to fix every phrase which starts from pp. Fastest fix I’ve found is to offshift the first note by a bit.

I tried increasing the ticks before expression map switches, but that created problems elsewhere so it’s not really an option for me.

I don’t think this is possible, no. The only thing that springs to mind would be to turn off Reset controllers and send ‘all notes off’ when stopping playback in Preferences, but I think this really does only affect what happens when you stop rather than when you start playback, so I don’t think it will help.

The problem I have is not so much about starting or stopping playback, but it’s this ”edge” just before and after a phrase. When there is a rest, dorico automatically draws CC1 at 64, but many of my libraries catch this edge and there is a very audible ”spike” in the sound when quiet note starts or ends.

I wonder if I could trick dorico somehow to think that there are no rests?

Would it be possible to alter this behaviour so that CC1 does not return automatically to 64 whenever there is a rest, but stays where it was left? Or can there be something in my expression map that is causing this?

I studied this a bit further, it seems that it is the note length conditions that cause the CC1 to reset.

Here is a typical problematic situation that I have been facing:

If I take off the different note length conditions from my expression map, these problems disappear:


I have this problem too. Can you explaing a bit more about the note lenght conditions, and how changed them? Thanks, H


I simply had to take off almost all note length conditions, since I couldn’t find a robust solution to the problem. But these ”CC1 reset to 64 glitches” can happen also when switching an articulation, it is not just between note length conditions.

The problem is that it is a bit hard to create an easily reproduceable case - it can be that the problems arise only after the document is relatively big.

@PaulWalmsley Have you experienced these problems with CC1 resetting to 64 when building expression maps? They can be bit tricky to reproduce, but the screenshots I’ve posted earlier should give an idea of the problem.

Thanks, I am not so fluent in adjusting the expression maps… is this done in the Expression Map dialogue-window? Maybe you could point me to some documentaion on this, can´t find it the manual…

I haven’t had time to look at this issue, but I’ve logged it in our database.

Thank you!

Here is actually a cut down project in which I’ve managed to recreate the issue:

CC1 testfile.dorico (383.8 KB)

I’ve added comments to the exact points where it happens. This file only demonstrates the “CC1 spikes” between different note length conditions, but I’ve also experienced them between articulations.

What expression map and vst-library are you using?

You can edit the note length conditions here, if that is what you are asking about:

Apart from the Dorico manual, you can also find great videos about creating expression maps in youtube.

BBCSO Pro, using John´s maps.
Thanks, I´ll learn more about this.

Thanks for the repro steps - I’ll attach to the entry.

1 Like

I must say, I don’t think I can think of a single instance where a dynamic controller (such as CC1 or 11) has ever shown a reset to 64 in the automation lane or indeed the VST interface during the progress of a piece with any library – most of which include NoteLength the EM’s. So I’ve no idea how to reproduce your problem, even though the evidence is there and I can’t find anything odd with the testfile EM. It will be very interesting if Paul manages to explain it as it is bound to give further insight into the inner workings of Dorico

The practical problem of spikes at the first note of a phrase in particular which is very real can, I’ve found, be largely eliminated with both BBC SO and CSS libraries by setting the velocity (when the main dynamic controller is CC1) to between 20 and 63 on the note(s) in question.

Could you post a screenshot or a project file of the problem you are having? It could help to locate where the problem might be, as your expression map is different from mine.

I managed to minimise the problem, using the text “nat.” instead of “ord.”, strangely enough…

See images. Prior to this passage, the strings are playing “Flautando”, and if I leave out the “nat.” or “ord.” they reset bak to that technique, which doens´t spike in volume as much as the natural.Skjermbilde 2021-02-04 kl. 21.09.38

Skjermbilde 2021-02-04 kl. 21.09.45

This seems to be somewhat different from what I have been experiencing, as my CC values were reset to exactly 64 and your spikes all with different values. But good that you found a solution!

I guess the only common thing is that these spikes can happen whenever there is a rest (and thus a change in articulation).

On the same subject;

I get frequent “attacks” on the start of notes, even when marked pp, (especially Horns in BBC Pro)

I have turned of the humanize and start of note dynamic-settings in the Playback options.

It’s interesting that you have problems with the Horns in the BBC library as their legato dynamics in particular are one thing that seems to have been significantly smoothed out exactly with the v.1.2 player update (you have installed it, I take it, and downloaded the new samples?). Anyway, zeroing stuff in the Dorico humanize is the essential first step but I suggest you also try a couple of things.

One is what I mentioned already about reducing the velocity to between 20 and 63 – however not all patches in the BBC respond to this apart from obviously the shorter ones which tend to be velocity controlled. Some experimentation is useful. The other is to reduce the CC1 level to reduce the attack and to compensate, increase the CC11 to get back the lost volume. Using CC11 and CC1 together is one of the keys of getting useable results out of the BBC Core and Pro libraries.