Default click-drag behavior broken i Dorico 3 ?

No matter what I select (Hand Tool or Marquee select tool) I have to shift drag to move the score. With no shift I always get the Marquee tool.
It worked in D 2.
Any suggestions ?

I’ve spotted this too, and I don’t have a solution.

I searched the version 3 keyboard map. It says H is “Toggle between Hand and Marquee Tool” and it works for me.

It doesn’t work in preferences, but it DOES work if you select the hand tool icon at the bottom/right side :nerd:

Speak for yourself, Mads! That doesn’t work for me.

Sorry to hear that… - maybe it’s a mac/win thing ?

I’m talking about my Windows machine. I can’t scroll horizontally with two fingers on the touchpad anymore. It still works fine in Dorico 2.2.20.

Actually, I realise now that scrolling is not quite the same as what you’re talking about. Sorry!

Mads, can you check what key command shows up when you choose UI > Toggle Between Hand and Marquee Tool in the Key Commands page of Preferences?

nothing turns up… - not even if I change language from default to English or German…

Try quitting Dorico and moving aside your own keycommands_en.json file (or whatever two-letter language code you see) from %APPDATA%\Steinberg\Dorico 3, then restart Dorico and see if it works. If it does, then there’s a problem with your custom key commands file of some kind.

I found the keycommands_en.json file in
C:\Users\Mads\AppData\Roaming\Steinberg\Dorico 3
It makes no difference if I remove it…

I have tried this on both Windows and Mac here and have not been able to reproduce any issue: H correctly swaps between the two tools, and the behaviour of clicking and dragging the music reflects the current state of the tool. I’m afraid I don’t know what else to suggest for you at the moment.

Sorry to pile on here, but I have a similar problem. Default is marquee, though I’ve always had it set to drag. H doesn’t switch them; I have to click on the icon.

I am able to drag as expected once the correct tool is selected.

Can you similarly try moving your own key commands file out of the way, Dan, and then restart Dorico and see whether the H key command works as expected?

That worked. Though I don’t understand why.

Json attached, if it’s helpful. (1.62 KB)

Dan, you have a conflicting shortcut of H assigned to the Edit > Hide/Show Item command.

How embarrasingly basic. Thanks Daniel. Apparently I had added the H-hide command long after settling on the drag funtion, so I never tried going back to marquee. :blush:

Ups - same thing here - though I don’t remember setting this shortcut. :confused:
BUT - this shortcut doesn’t work… - nothing gets hidden… :confused:
Thank’s :slight_smile: