Default color settings for tracks?

I went to preferences, appearance>> colors>> track type defaults and made my changes and hit apply, but the colors a pretty random when adding track types, its not following my settings at all. Any ideas?

Did you restart after saving the preferences?

Go to “Preferences” -> “Event Display” -> “Tracks”. Here you can choose different options for the “Auto Track Color Mode”. In your case you have to choose “Use Default Track Color”.