Default Empty Bars Rests Missing In Some Staves

I’m copying and pasting notes from an xml file into a new score. Some empty bars in staves following the end of the copy and paste sections now have no default rests in them whilst other empty bars in some staves have them.

I’ve checked that “Show bar rests in empty bars” in all options are selected in Layout Options. The only way I can get the default score with rests in empty bars on all staves is to delete all the following empty staves then re-add them which results in all empty bars in all staves with the default rests.

Can anyone suggest how to restore the empty bars rests?

Thanks.

This is a fairly common problem specific to MusicXML imports. The first note of each flow will have the “Starts Voice” property turned on, and the last note in the flow will have the “Ends Voice” property turned on. The solution is to find the last note or rest before the bar rests disappear, select it and turn off the “Ends Voice” property. Then find the first note/rest after a period of no rests, select it and turn off its “Starts Voice” property.

Hello Pianoleo,

Thanks for replying and your suggestion.

That worked. After some searching through the score I eventually found those last notes and turned the default rests back on.

Hello Pianoleo,
I have the same problem with default bar rests not showing up. My score, however is not a Music XML import and have searched for incompleted voices and found none.

You should be able to force them in: double click on the staff at the first bar in which rests are missing, then type Shift-B rest Enter (or use the Insert Bar Rest button in the Bars and Barlines section of the right panel).

Thanks, pianoleo, it worked - like magic. All the best. Kerry

1 Like