Default music font goes wild…

Dear Daniel,

Here’s a description of what I have when I open a new document in Dorico 3.5, after I have installed the MTF SMuFL fonts and BopMusicSMFL font.
The template shows, and the music font is BopMusicSMFL font. (Picture 1) (Daniel, note that the instrument names show correctly in French on a new document) I open the Edit Font styles window, change it to Bravura, and it changes to Bravura. In Engrave mode, I open the Music Fonts… feature in the Engrave menu, and Apply Bravura (along with the two ticked options at the bottom of that window), and now the music font used is MTF Arnold! If I open the Edit Font styles (picture 2) and apply Default music font to Bravura, then everything is as I expect it to be from the beginning.
Any idea of what could cause such mess? Anything I could upload here to help you track this down? Am I the only user affected by this?


Edit:
Sorry, wrong answer!

Oooh… this is interesting.

I open a project where I use Bravura. In Engrave mode, from the menu I select ‘music font’, the window shows Bravura being applied.

I close that window, and open ‘Font Styles’, I look under ‘Default Music Font’ and it shows MTF-Cadence (not Bravura). I click cancel.

Dorico applies MTF-Cadence to the project.

I will link a video.

https://drive.google.com/file/d/1bLez8yqBXawXfCna4bO4FlsAyAzjROzn/view?usp=sharing

Robby

Sorry, apparently the link was set to private. Try it now, if there are issues, post here.

in case the link changed:

https://drive.google.com/file/d/1bLez8yqBXawXfCna4bO4FlsAyAzjROzn/view?usp=sharing

Robby

Glad to know I am not alone on the messy track of SMuFL fonts :wink:

I can reproduce this - it seems what is happening is if you go into Engrave -> Music Fonts and simply click OK without changing anything, it applies the font that happens to be at the top of the list instead of the currently selected one (in blue). In my case, BopMusic is at the top of the list and when I am using Bravura and I go into Engrave -> Music Fonts and simply click OK (with bravura in blue already because I am using it), everything changes to BopMusic unexpectedly.

EDIT: At least on Windows, There is a dotted outline around the topmost font in the list, suggesting that it is selected, while Bravura is in blue. If I manually click on Bravura, the dotted outline moves, and then clicking OK does not result in a change to BopMusic.
Dorico-Fonts.PNG

Edit: The below part is COMPLETELY FALSE.
It seemed to work, but I could not produce the same result twice. Dorico changed the font on me.

I found this today…

On my Mac, while trying to copy gliphs from Bravura, Font Book told me I had a 2 similar fonts of Bravura installed. I hit resolve automatically, closed Dorico, and reopened.

The font no longer changes as it did in the video I sent.

Perhaps, Dorico (or the OS) is having trouble choosing between the correct font, and opening the window forces Dorico to choose something, and maybe not what we expect.

Just a thought!

However, I found something else out, and this goes along with the post above… I believe just opening the music font dialogue causes Dorico to choose the font at the top, despite which one is highlighted. I will attach a short video clip.


Robby

Here is the video link, give it about 5 minutes to process, and it should be ready.

Robby


https://drive.google.com/file/d/1hMY6D_R95t9k1C0XsPJ51P9fB9ixRnk2/view?usp=sharing

Yes, that is what I said in my post above. When you open the music font dialogue (on windows at least), the font you are using now is in blue, and there is a very thin dotted border showing that the topmost item in the list is selected. If you are not currently using the font that is at the top of the list, then the font shown in blue will be different from the font that has the dotted selection box around it. If you click ok, it changes to the font with the selection box around it. You can see the dotted border in my last post.

Thanks for reporting this. If you have a music font whose name comes before ‘Bravura’ in the alphabet, then the Engrave > Music Fonts dialog will go wrong if you simply open and then confirm the dialog; even though it looks like Bravura is selected, in fact under the covers the dialog thinks the first item in the list is selected (due to a subtle bug in the Qt framework we’re using). We can fix this, and we will fix it for the next update. Marc, I hope this also explains the problem you’re experiencing; if not, and you think there’s another explanation for what you’re experiencing, please let me know.

Thanks to mducharme and Daniel for chiming in, this bug certainly explains the Music Font dialog problem. What is still to understand is why every new file starts now with BopMusic font… I cannot find any default music font setting anywhere (apart from the buggy window). Now that I write it, it might be the explanation. But then, why does MTF Arnold appear? I have to check that out carefully. Again, thank you for your interest in this!

Marc, I noticed that since the first day I run Dorico when I investigated my BM and RS fonts, each time I have a previous font setting applied to the new switched music font.

+1