Define zoom height for Zoom Selected Tracks

Cubase Pro 11: Can anybody tell me how I can define how many lines a track gets zoomed to when I use “Zoom Selected tracks”? I did not find anything in the Preferences.

To set:

  1. Select a track.
  2. Activate zoom by pressing Z.
  3. Adjust manully the height of the track (that will be the default value until changed to something else).

To test:

  1. Deactivate and reactivate zoom by pressing Z twice.
2 Likes

Does that work on your installation? It didn’t work on mine.

1 Like

Yes, it does. Make sure Z is not assigned to another function. Also, the effect would not be visible if the heights of the selected track in and out of zoom happened to coincide.

1 Like

Weird, it doesn’t work for me. I installed Cubase 11 fresh on this system and did not assign “z” to any other command.
On my system also all tracks get adjusted to “1 line” when using z. Do you have the same?

Before:
Screenshot 2020-12-20 181146

Pressing z:
Screenshot 2020-12-20 181247

Pressing z again:
Screenshot 2020-12-20 181320

The screen shots look correct. Pressing Z enlarges the selected track. Change its height manually and that height will be a default for Z.

After pressing “z” I make the track one or two notches slimer. But then I press z again and it goes back to this zoom that you can see in the second screenshot.
Pressing z again results in all tracks height = 1 line. So the previous view is not restored.

I am puzzled why it works on your machine and not on mine.

Not sure what’s happening on your end. Remember Z is a toggle between the active and inactive states of “Enlarge Selected Track.” You should be adjusting the default zoom height when in the active state. Make sure you’re not doing the inverse.

1 Like

I understand the procedure but I get a different result from you. I tried also from the Empty template, where I just created some tracks. Same behaviour.
Thanks @Aivaras.

Maybe somebody else have an idea why my client behaves this way?

Yes, this is something that I feel is badly implemented. I like to have my project tracks set up to 2 rows per track and have created a macro to do just that.

However, if I zoom a single track (using Z) and then deactivate that single track zoom (using Z again) what happens is ALL the tracks now revert back to a single row zoom. So I have to invoke my macro to get back to 2 row zoom.

Essentially unZooming restores the state of the zoomed single track but then goes and changes all the other tracks to single row height. I don’t think that’s right.

1 Like

Hey, @Johnny_Moneto, it’s probably because you have your Z key set to “Zoom>Zoom Tracks Exclusive”. It behaves the same way for me as you describe.

But if you assign Z to “Edit>Enlarge Selected Track” then it behaves as @Aivaras says. The problem is that if you don’t want every track you select to automatically be enlarged, and want to use the key command as a “zoom” command instead, you will be greeted with a notification “Activated: Enlarge Selected Track” when you give the command and “Deactivated: Enlarge Selected Track” when you give it again.

In my opinion “Zoom Tracks Exclusive” should work like “Enlarge Selected Track” regarding setting the track size. It should maximize the size of the selected tracks, allow us to modify the size, minimize the rest of the tracks if it should, but when given again, the command should restore all sizes to how they were before the command was given.

1 Like

That explains the different results between @Aivaras and myself.
As I mentioned in my second post I use a totally fresh install of Cubase and Z is assigned to “Zoom>Zoom Tracks Exclusive” by default.
I already switched to use “Enlarge Selected Tracks” as “Zoom Tracks Exclusive” does not yield the result that I need as it messes up my settings for track height and the zoomed track height cannot be adjusted to my needs. I wonder if anybody uses that function and is happy with it.

Thanks guys, I will mark this as solved as I have a working solution now. Even though it feels the actual function “Zoom Tracks Exclusive” needs an overhaul.