Delay Bypass Automation causes glitch in Export.

Re: Delay Bypass Automation: (non-emergency) :slight_smile:


Normal project with 20 or so tracks.Using stock plug-in Mono Delay only.

One track has a piano part being played by a VST instrument playing a sample loop.

The track has a Mono Delay with the Bypass Automated.

I want Bypass OFF to hit on the last 16th of a previous measure resulting in syncopated delays.

It works fine in Cubase, but the export has a glitch at those points where bypass Off is not on the measure.

I’ll try real time export. Perhaps that will clear it up. Rendering the tracks might also get it done. No emergency on this or anything. Some kind of latency somewhere…odd enough that thought I’d mention it here.

Those syncopated delays are a nice little sound, but the only thing that worked so far was having the bypass hit on the first beat of a measure, otherwise I get a timing glitch in the exported mix. Anyway, there’s more than one way to skin this cat, too, I’m just now considering.

Thanks for any thought about it.

It’s hard to say if it’s related to your problem, but fyi, effect bypass is broken. It’s noticeable with delay effects:

https://www.steinberg.net/forums/viewtopic.php?f=283&t=195481

Thanks for the reference to the other thread. Seems like a “known issue,” perhaps? I think I’ll be able work out how to create the sound I want with other methods, but what appears the obvious method to me – a simple plug-in bypass automation – seems to have a possible bug.

Thanks for the note on this.

Is the export done in Realtime modus?

No, but I’m going to try that to see if that corrects this. I’ll also try Rendering the tracks.

if your delay on/off is happening on a bad position it will introduce clicks and pops sometimes
the better way to do this is to use a send FX instead
there you can fade in the FX return on the notes where you want it
or automate the send for the notes that should get delayed…
even very fast fades will work…

I’m not using a Send. I was using an Insert.

The Bypass is on and then turned off (Delay On) at the last sixteenth note of the previous measure. The result is syncopated delays. It’s not a “bad position” it’s where I want the Delays to hit.

It plays back perfectly in Cubase, no clicks (and I do know what you mean about that) or other glitches. The problem is that the Exported Mixdown glitches at the point where the Insert Delay Bypass is turned off, allowing the syncopated delays to be heard.

I still have to try 1) Rendering the track, 2) Trying Real Time Export, 3) Perhaps using a Send with a similar automation scheme.

If hou are not hearing it during playback it will be the same when exporting in realtime.

As I said, I’ll try that, or just render the track. Thanks.