Delay – inputting notes

Hi!

Whem I’m inputting notes by my keyboard, the audio feedback always has delay of appr. 1/3 second. Thats confusing, if I want to put in notes quickly. Is there any possibility to minimize the delay?

I just use the on board audio speakers of my laptop and Noteperformer.

Thanks in advance!

Hans-Peter

How are you inputting the notes? Adding them in step time is a lot different than using real-time MIDI, and it would help us help you if we knew the specifics.

Hi Derrek!

I´m not sure, if I understand your question correctly. I´m inputing the notes like I´m writing this post.
Selecting lenght by number, pressing a letter. My problem is, that there is a delay between pressing the letter and hearing the sound, which is confusing.
So there is no midi interface or something like this. Just the laptop, a keyboard, a mouse and a display …

Is the response faster if you use HALion instead of NotePerformer during entry (and then switch to NP later for playback)?

I don´t know. If I switch to Halion I have no sound at all. Maybe I´m doing something wrong (I´m good in inputting notes, but not in configuring the playback …)

Use the Playback Templates, one to switch to HALion sounds and another to switch back to NP.

Thanks! Its interesting, that NP has a much shorter delay than Halion which doesn´t playback every note, e.g. when I write a line of 16th-notes or a line of 8th-note/8th rest(right arrow)/8th note/8th rest etc. So, I will work with NP like before.

Hi!

Whem I’m inputting notes by my keyboard, the audio feedback always has delay of appr. 1/3 second. Thats confusing, cause I want to put in notes quickly. But the delay in the feedback (which is important to control by ears!) slows down the workflow.

So, its:

Button
… … … Beep

instead of:

Button
Beep

Is there any possibility to minimize that delay? (I tried: There is no big differnce between the HALion, NP etc. in respect of more or less delay)

I just use the on board audio speakers of my laptop and Noteperformer. And: I´m a greenhorn in terms of audio setups …

Thanks in advance!

Hans-Peter

PS: Macbook Pro 2019, latest Dorico Pro

Didn’t you already ask this question?

https://www.steinberg.net/forums/viewtopic.php?f=246&t=195986

Yes! :wink: And thanks for your help again!
But today I´m writing scores again for hours and it sucks that the audio feedback is always playing something like an offbeat. So, I tried to start this thread again. You know, I have a quite powerful laptop and no gimmicks connected to the computer or other programs open or so, so there should less delay than a computer in the 1990s.

Bumping threads creates additional work for the Dorico Team, and it’s unnecessary, since they keep track of every post here until the problem has been addressed. I’m sorry for your frustration. I have felt that way myself over the years, if not with Dorico than with other programs I have used.

I have merged your new thread into your existing one. Please post a further reply to your existing thread rather than starting a new one.

You might want to try reducing the buffer size in your audio interface settings, which you can access via the Device Control Panel button in Edit > Device Setup. If you don’t have an external audio interface, like something in the Steinberg UR series, or the Focusrite Saffire, or something similar, then that is your problem, and you should buy a good quality audio interface with good ASIO drivers in order to reduce the latency in your system.