Delete Bar

Great program concept. Congratulations!

Have problems deleting the last bar of a flow. Shift B -1 doesn’t work.

It works when I add some bars and delete them again. What is special with my last bar?

See attached file!
Bildschirmfoto 2016-10-26 um 08.54.01.png

Try Write > Trim Flow. If that doesn’t work, please zip up and attach your project.

Thanks Daniel. In the meantime I found out myself. But what is the reason? Why doesn`t Doric delete the last bar with Shift B -1? I am just curious.

it’s just a bit temperamental - I had the same issue one afternoon, but the next morning Shift-B -1 worked fine… :slight_smile:

Soundplane, if you attach or send a project where -1 doesn’t work, and can take a look. It should do really.

Here You are. I also don’t know how to hide the empty staves.
Deine Hand.dorico.zip (637 KB)

Write > Trim Flow won’t delete the end of the music because of the explicit double barline you’ve created at the end: delete that and then Write > Trim Flow will work.

Typing e.g. -2 into the Shift+B popover won’t currently shorten the flow beyond its current minimum length, which is why putting the caret near the end and trying to delete bars doesn’t work as you might expect. I’m not sure whether or not we will change this.

To hide empty staves, use the options on the Vertical Spacing page of Layout Options (in Setup mode).

It seems to me this is something many users may bump into: Can’t trim the flow because of a double barline, which looks LESS like a user-created object than the default final-barline, which of course trims fine. You’ll probably save a headache if you allow Dorico to remove such barlines when trimming.

Dear, Daniel
I am trying to delete first 24 empty bars with Write> Trim Flow action but no chance. See attached zip file of the project. https://dl.dropboxusercontent.com/u/518592/Everything%20Connected%20Everything%20Else.dorico.zip

Trim Flow only works on the END of a flow, not the beginning.
In write mode select the first rest in bar 1 (any stave), type shift-B and then in the box type -24 and then enter/return.

I’ve been struggling with a variation of this for 30 minutes. Thought I’d found the answer here, but this method deletes a bar from all staves, which is not what I need.

I imported a SATB MIDI file, and for some reason, Dorico added an extra bar of rest in the piano track. So, while the vocals all begin at bar 1, the piano has a rest in bar 1, and then the music (which should be at bar 1) starts in bar 2. So, all I want to do is delete the unnecessary bar of rest in the piano track ONLY. But so far, this has proved to be phenomenally difficult and unintuitive. For heaven’s sake, why can’t I just select the rests and hit delete?! I really want to like Dorico, but everything seems so unnecessarily obtuse.

Bottom line: How do I delete a single bar of rest from ONE instrument (but not the other instruments), then have the remaining music shift to the left by one bar???

If you hit I (to turn on Insert Mode) then you CAN select the rests and press delete!

Thank you!!

What is the thinking behind “insert mode”? I ask because I’m genuinely trying to understand Dorico. Why would a mode be required for this at all?

Think of it like Overwrite mode in a Word processor.

Sometimes you want to overwrite what’s already there, and sometimes you want to Insert and nudge along what’s already there.

I could elaborate but I’m sure other people have already done so on this very forum, probably in a more eloquent way than I could.

I still do not understand why there is a such confusion with -10 or -200 or even with trim flow. What is an idea behind it? Why not to let a user just to delete a selection? There are often some situations where you do not want to count all the bars. For example when you are going to delete several pages of imported XML. In such cases I have to guess an amount of bars I would like to delete. So, I write for example something like -150, press enter and then see if I need to delete more bars or undo it and do it again starting with something like -100 or so. When I would like to delete several last pages of a flow, I have to delete all the notes, time signatures an other information first to be able to use a trim flow function. But if I already know I do not need all the musical text there, why I am not able just to select and delete it? Quite confusing and time consuming.

We will certainly add further options for deleting bars more directly in future. We have plans for a whole new user interface element to make these kinds of operations easier and more obvious to perform, but we haven’t yet had time to implement it.

Great to know, Daniel. Thank you:)

Same thing here, yesterday shift+B -1 wouldn’t work, neither “Trim Flow”. Today, after a computer restart, it works as expected.

I suspect that instead of rebooting, in this case it would be sufficient to just close and re-open the score. Dorico has a ‘clean-up’ phase when loading scores that will remove orphaned, redundant or erroneous items. It’s quite likely that the presence of one of these was preventing Trim Flow from working.