Delete Overlaps in MIDI part with Right Click?

I didn’t know about this function, but I swear it just popped up while I right clicked in the vicinity of two overlapping MIDI Parts. Very handy. Problem is, I can’t get it to pop up again. Right clicking just gives me the tool selection bar. I searched the manual, but can’t find anything about right clicking and delete overlap. ( I think the right click menu as “remove” overlap).

What’s the secret? :wink:

Thanks,
Mahlon

You can find “Delete Overlaps” (for MIDI tracks) in the MIDI/Functions menu. See Page 477 of the manual.

If you hold down a modifier key while you right-click you will get a context menu which, with MIDI selected, will include MIDI Functions.

If you want the context menu to always appear on a right-click then disable “Pop-up Toolbox on Right-Click” option in the Preferences dialog.

Thanks, Jenks.

I’m not at the Cubase right now, but I remember holding down a modifier key and right clicking and seeing a long list of the MIDI functions available. What I’m talking about was a small popup box with only the two Parts I had selected named, and then just beneath that the phrase “Remove Overlap from Parts”. This was different from the long list of functions. Is this small box what you’re saying should pop up?

Thanks,
Mahlon

P.S. Good to know I can disable the Tool menu popup.

Anyone ever seen this? I’ll try to do a screen capture next time it happens.

Mahlon

You must be talking about Remove Overlaps from audio events.

This was definitely MIDI as I have no audio events in the project. I had two overlapping MIDI parts selected in the Project Window. It was a small popup window (not the long popup with list of functions when you CNTRL/Right click) that only had three items listed: both MIDI parts and the option to remove the overlap.

Mahlon

Oh, now I see… Click on the “To Front” triangle that appears in the bottom middle of an overlapping part. (Same as with Audio events)

I have never actually used this in midi. :astonished:

There is a small pull-down arrow on the parts… click that and you will find the option you are reffering to. It’s not a right click option, and both parts don’t have to be selected.


ahh… never mind… I see Steve found it for you as well.

Thank God! I thought I must see things or drunk if no else was seeing this. My MIDI parts are vertically narrow – so this is why I couldn’t reproduce it easily.

Thanks for the help and the answer.

Mahlon

I don’t see that arrow in Cubase 7.5.30 I wish “Remove Overlaps” command worked on MIDI as well as audio. I don’t see a way to do this for MIDI regions. If I click on the little box in the center then it just switches between which part is on top. Remove Overlaps Polly and Mono in the MIDI functions menu is for MIDI events and not the regions themselves. I am sure I am missing something.

Update: I just realized that it doesn’t show the triangle if you have lanes open. I’m all good now, hopefully there will be a way to do this on a mass selected scale in the future, like “Remove Overlaps” for audio does.

Does anyone know how to do this for MIDI while selecting all the regions rather than having to click on the dropdown triangle?