Delete time leaves tempo track intact

When I used to delete time in Cubase, the tempo track would reflect the change I made…

Since upgrading to 8 and 8.5 this isn’t the case… is there an option somewhere?



It works to me, here (Cubase 8.5.0, on Mac). Isn’t your Tempo Track locked?

Could you try to make step-by-step description with the most of details, you can write down, please? Or make a screen-recording.

Just tried to reproduce and it’s when I import a tempo track.

After it’s imported… delete silence doesn’t affect it.

I have just tried this myself, to see if you were going wrong somewhere… you are absolutely right! Confirmed here on Mac :slight_smile: (Tested with Tempo Track present in Project window)


OK, now, I can also reproduce it. But only, if any tempo changes already were in the project before the import.


Its a real pain if you’re trying to do 1min and 30sec cut downs of a track for library with tempo changes. I’ll have to use a previous version of cubase!

Is that the only workaround?

This is very significant for me.

Perhaps using the Arranger Track to make the Edits you want and then “Flatten” would get around the issue?

Haven’t tried it but sometimes when working on a new bit (especially Post type stuff pre picture) I end up, initially, with different sections all along the time line in totally the wrong order.

Even with EXTREME Tempo and Signature Tracks the Arranger Track puts things in the right order for me with no issues.

Much easier than Cutting and Pasting forever.


Being a rather stubborn individual here, I’ve been trying a few things, and I think I have actually found a workaround (I’d love to know if it works for you too :wink: )…
After having imported the Tempo track, duplicate the Tempo Track Version, and use the duplicate instead.
“Delete Time” now works!

However, there’s something really odd…
go back to the 1st version (which should include your imported tempo, but, instead it reverts to the tempo track as it had been before you imported).


As a workaround “Cut Time” works to me. Can you no form this?

I’ll give it a try… hang on…

… Yess… works just fine :slight_smile: