Delete Time - Not Working

With “Editing - Cycle Follows Range Selection” enabled and Tempo Track Unlocked

Cubase Pro 8.0.10

  1. Make a Range selection in the tempo track and
  2. Edit - select in loop
  3. Edit - Delete Time

The tempo track no longer deletes time like in Cubase 7.5 and earlier.

  1. Use Edit - Insert Bars
  2. Change to “Delete Bars”
  3. Select the bars you want to delete and press process

All tracks but unlocked tempo track deletes the bars so tempo map is out of time. Both methods are broken.

Interestingly enough you can range select the bars in the Tempo ruler and delete time but then you have to try to make the same selection to delete the other tracks bars which is a little difficult with time signature changes and a different tempo map.

Maybe I am not following your recipe correctly here, but, for me…

  1. When the Range Tool is active, this overrides the “Global” nature of Cut Time/Delete Time/Insert Silence, and acts instead on the … errm… selected Range :wink:… so if the Range encompasses only the Tempo track (i.e. in the vertical selection), that will be the only track that is affected. (the actual position of the Left and Right Locators is also irrelevant… it is only the selected Range that counts). And (most importantly in this case;) when I “Select In Loop”, this does indeed select everything vertically, and they all then behave as expected.
  2. There is no difference here between the behavior in Cubase 7.5.40 and Cubase 8.0.10

(just wanted to add to my previous reply (which is still in the hands of the Moderators, awaiting confirmation :wink: )…
Are you using the Track Divider (with the Tempo track in the upper section, and everything else in the lower)? This might have an effect on what is selected with “Select In Loop”… but you’d still be able to see if all tracks had been selected or not :wink: )

Thanks for the reply Vic I was excited when I saw that you replied because I knew something good would happen.

To sum things up it turns out that apparently there was a glitch (as far as I can tell) I created a new tempo track version (which is kind of hidden and seems like it should have an inspector tab like the tracks do as of 7.5) and it all worked as expected. I opened the project up in 7.5.40 and it didn’t work their either. I am sorry for not checking the project there before posting.

Correct but if you don’t have that preference on then when you press select in loop it will select everything between the left and right locators. Just generally easier for me to use the range selection with grid on to select what I want to remove and have the left and right locators updated automatically.

I do always use the Tempo track in the Track Divider but actually pulled it out and even turned off track divide and moved the tempo track to multiple locations before I posted this but nothing worked. Kind of strange, maybe there is a way to lock a Tempo version separate from the actual lock on the track itself. You can’t lock tempo events individually, at least not with the lock command I just tested.

Also one thing I didn’t include (because it doesn’t mater with using select all in loop) that I usually do is range select and then switch to the object selection tool so nothing is range selected and then delete time but that didn’t work either in this case.

I guess this can be removed from the bug list, just seems like a bug to the session at this point. Thanks again Vic_France

So that’s good news both for yourself, and for Steinberg :wink:

Has this ever been resolved? I have the same issue again in many projects. Thank you.