Destructive Split audio events

I have 4 tracks (2 stereo pairs) which were recorded with a multitrack recorder in wav format and I’ve imported them to a cubasis project. They are 4 mono files panned hard left and right on 4 track lanes in cubasis and I need to trim about 30 mins off the beginning of each one without throwing each track out of sync

I’ve split all 4 events in exactly the same place (using snap to grid in the main timeline view) iand moved them to the beginning of the project. This works well but I’d like to discard the unused audio on each track before doing any more work on the project as they are taking up too much free space on the iPads storage

The only way I can see to delete a section of audio is within the audio editor but the chances of me selecting exactly the same start point in all 4 audio editors is slim to nil and snap to grid doesn’t seem to affect the audio editor

Is it possible to trim the unused audio without throwing the tracks out of sync ?



If you,ve split the audio track, click on the portion of the audio you no longer want and it will turn darker to show it’s been selected. Next, hit the erase button. That portion will be deleted and the remaining portion will still reside in it’s proper position.

Note, you do this one track at a time.

If you are concerned about doing something you can’t undo, make a snapshot of your project file first.

Thanks Akamarko, Sorry for the late reply,

Finally got a chance to try out the solution above. It looks like you described the steps I already took. I’ve tried it again with a test project and fresh audio tracks but when I erase the audio preceding the split, it just shortens the audio event in the track lane but the full audio is still there if I open it in the audio editor.

I could delete the unwanted audio in the audio editor but if I do that the individual audio tracks will not be the same length as there’s no snap to grid or sample length indicator in the audio editor. This means I can’t split the audio at exactly the same point in the audio editor which will throw the tracks out of sync

Is there any way to trim all audio tracks to the same length and discard the unwanted audio ? (The session is 4 tracks and each track is 2 hours long, I only need the last 20 mins of each track so I’m wasting about 2gb of space on the iPad if I can’t discard the beginning of each track at exactly the same place)



After deleting the unwanted portion of your audio, you can drag the ‘wanted’ section any where along the timeline. on the far right of the tools palette in the normal track view, there is a snap too selection button. You can snap right to the beginning of a bar, or the nearest 1/2 note, 1/4 note etc as well as snap off for fine precision placement in the timeline.

In the track view you can split the audio events on the grid so all tracks are split in the same place, unfortunately you can’t discard the unwanted audio here so I have 1hr 20mins unused audio per track which is wasting a lot of space on the iPad

In the audio editor you CAN discard unwanted audio and delete it from the iPad’s storage but there’s no grid so you can’t edit them all to the same length, this throws the tracks out of sync

I need to flush unused audio in the event view to clear it from storage but this can only be done in the audio editor where there is no way of editing the tracks to the same length

Perhaps the only way is to mixdown each track to a separate wav and re-import them one at a time, then delete the originals ?

Here is a tutorial I just did. Hopefully this helps with your problem. If not, I’m not sure what will.

Thanks for taking the time to make that tutorial, really appreciate your effort on this :slight_smile:

That’s the same method I used to split the tracks but,

If you double tap the remaining audio in each track the audio editor should appear

The audio editor shows that the entire audio file is still there.

The beginning hasn’t really been removed.

The split and erase just changes where the audio events start from.

It’s not a problem with short audio files but with 2 hr sessions it would save a lot of space if the split / erase could be applied to the original file


so here is my take :slight_smile:

I cannot think of a “proper” way to solve your problem from within Cubasis. The audio editor and the arrangement view are independent, so you will almost always cut the events to different lengths.

Just an idea (you might have already tried it):

  • Change the time display to milliseconds
  • Align all events at zero
  • Put the playhead at the position where you want to cut the events and note down the offset
  • Open the audio editor and select a very high zoom level and trim the event according to the offset.

I haven’t tried it myself, but there might be an at least non-audible offset between the events.

Kind regards,

On closer look I see that you are correct. I’m not sure exactly how one would permanently erase that unwanted portion unless they did a mix down of each (shortened) individual track, then delete the original project file, then create a new project and insert all of the indivual shortened mixdowns into the new project.

Hi Akamarko,

you win. Sounds like a very good idea :smiley:

Kind regards,

That’s about the only way I could see to do it, was just hoping to find a faster or simpler way, presumably I’ll need to disable all effects , panning and volume adjustments then copy the settings into the new project ( i don’t want to apply them directly to the audio files before the final mixdown )

makes good sense.

Just got chance to try both methods

First tried zooming in the audio editor but at full zoom the ruler showed the same number at two marker points

Perhaps an area in the audio editor which shows the start and end point location in samples is needed as found in soundforge and other audio editors, this would make precise editing easier. Even better would be to have the ruler show bars and beats and be able to snap the locators to them.

The second method (mix down to individual tracks) worked but the shortened rendered audio files were larger than the originals (probably the bit rate or sample was increased). The 4 shorter audio tracks are now taking up around 30 percent more space ! :laughing:

Sigh…1 step forward, 2 steps back. Lol :open_mouth:
Sorry I can’t figure out a proper solution for you.

No worries thanks for ur help :smiley:


I know this post is 5 years old, but I just encountered the same situation and found this thread really useful.

What I did was import all the tracks in Audacity and trim the tracks as a group. That keeps the timing in sync between the tracks. I then saved them as individual 32 bit Wave files. There is an option for “export multiple”. I then imported those files in Cubase. It seems to work well and I don’t think I lost any fidelity going to from on wave file type to another.

It’s not as clean as doing it in Cubase but it seemed like a simply workaround and doesn’t add too much to my workflow.