Difference between 6.5 & 10.5 to cause freeze

I have a 64bit win 10 laptop running CB 10.5 Unfortunately, my favourite (64bit) piano plugin causes CB10.5 to freeze when loaded.
The same laptop also has CB6.5 installed. When the same piano plugin is loaded into 6.5 everything is fine (no freeze).
Is there anything in 10.5 that can be enabled/disabled/tweaked, or anything that can point me to the problem?


You could try to experiment with the ASIO Guard. This is the only one, I can think of.

In any case, I would recommend to install the latest version of the plug-in.

Thanks Martin,

On your suggestion, I tried Low-Normal-High in ASIO Guard - Same results!
I should add, the standalone piano works fine outside of CB10.5
Also, the plugin worked fine on my old and retired Win10 desktop with CB10.5
It seems that the piano plugin just doesn’t like the CB10.5 version I have on my laptop :disappointed:
If anyone else has any suggestions I would appreciate it.


If it was working in C10.5 on the other computer, the problem is in the hardware.

What graphic card do you use, please?

Thanks Martin,

Graphics card: NVIDIA® GeForce® GTX 1050 Ti - 4.0GB GDDR5 Video RAM - DirectX® 12.1

Please bear in mind that:

  1. The plugin works as standalone
  2. The plugin works in CB6.5

Is it maybe a VST 2 instrument?

Thank mr.roos

In VST Plugin Manager it shows as VST 2.4


Please try this:

  • Download the latest Studio driver version from here. If there is no Studio driver for your graphic card, use the one, which is available and continue with the same steps bellow.
  • Disconnect the computer from Internet to make sure Windows will not download and install own graphic driver.
  • Uninstall the NVIDIA driver.
  • Restart computer.
  • Start the NVIDIA driver installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.
  • Connect your computer to the internet.

Thank you so much, Martin. You are my new hero.
The plugin works now :smiley:
I’m baffled as to why the plugin worked in CB6.5 but not 10.5, but no worries, all good now!
Thanks again, Martin. Much appreciated.