Different length displayed than expected -- ruler problem?

When I create a part for a Groove agent track and open the editor, the part in the editor is a different length to the part in the track, for example, this morning the track part was 2 bars long, but when i opened the editor it was 10 bars long. What am I doing wrong and how can I fix it?

Hi and welcome on the forum,

Could you attach a screenshot, please?

here you go!

Hi,

My guess is, the ruler in the upper part (arranger area) is not Bars&Beats. I would say probably seconds?

Hi Martin, thanks for getting back to me. I’ve checked the transport bar and that is showing beats and bars - is that what you meant? If so I think the problem lies elsewhere.
Chris

Hi,

No, I mean the ruler in the arranger area. Clock to the triangle on the most right side is the ruler and double check the scale here, please.

Hi, sorry, I’m an old an confused man who still thinks computers have dragons in them and run on fairy dust! I have checked the ruler, and the boxes for bars and beats, and bars and beats linear are checked.
I hope I’ve got it right this time.
Any ideas?

thanks
Chris

Hi,

Could you attach a screenshot of the settings, please?

Hi Martin, I have just downloaded the latest up date for Cubase and it appears to have solved the problem.
Thanks for all your help.
Chris