Direct Monitoring and The Control Room

Hi All,
I believe this is a bug, but if someone can explain why it isn’t and I just need to modify my set-up or workflow, then I’m open to ideas. On the face of it, this does appear to be a bug though (again, it might be down to me particular config!). Apologies for the long intro - but I want to set the stage correctly!

So:
I have my audio interface (MOTU 828 mkii - old, I know, but it works) configured for Direct Monitoring. In general, this works beautifully - no latency, I can have effects inserts, the whole works.
I have disabled all of the MOTU internal mixes so I don’t hear the internal mixer (I just unmute them for live stuff when I’m not using Cubase)
My point here is - Direct Monitoring, in itself, doesn’t appear to be a problem. My audio routes aren’t complex either:
Physical Input -> Audio Track -> Group Track -> Main Mix (Output)
I have auto monitoring mode set to Tapemachine mode

My Control Room setup is also (I believe) pretty ordinary:
In VST Connections, I have a “dummy” Output tagged as the Main Mix
I have two Cue mixes (one to a headphone amp, and one to the mix-in on a VDrums module)
I don’t use the Phones output as I want to be able to Preview on either phones or monitors without changing preferences
I have Monitor outputs for desk monitors, headphones, and a couple of other outputs that are pretty irrelevant (hardly used).
Audio track Monitor select STOPS monitoring.PNG
When I select monitoring (the little speaker icon) on an Audio track, the monitor audio doesn’t come through until I ALSO select one of the Source Mixes in the Control Room. It doesn’t matter which Source Mix I choose (Mix, C1, C2) (even if it’s the one that’s already selected), but it does matter where I select it. So if I select a Source Mix from the Main CR section, I will hear the Direct Monitor audio. If I select a Source Mix in one of the Cue Mix CR sections, I will hear the Direct Monitor audio there instead.
CR monitoring after reselect.PNG
I can appreciate that Direct Monitoring perhaps only be routed to one output or cue, but the issue is that if I then change the monitoring config on the audio track (the speaker icon) then this breaks the routing at the CR and I have to then re-select a Source Mix to re-establish the route.

Surely there should be some persistence to update the Direct Monitoring to the last selected CR Source Mix, or a setting in the CR to say which output should receive the Direct Monitor audio?

Or… after all that, am I doing something wrong?

Many thanks,
Oliver

To add to the original post:
It appears that the Direct monitoring mode has (as one would expect) an impact on when the routing is adjusted. I’ve changed the mode to “Manual” which isn’t really what I want, but at least now once I establish the routing (by selecting DM on the audio track, and then clicking on a Source Mix button on CR) it remains routed between takes (though I don’t hear any audio that’s already on the track).

Same here with 828 mk3. I’m able to established audio monitoring properly de-activating and activating again the monitoring button on the track. That’s a bug, of course.

Sorry for the late response.

Thanks for following up Lordadb - Steinberg just brushed it off…
I ended up upgrading my MOTU interface to a 1248 and the problem has gone, so I guess it’s a combination of Cubase/driver at play here, so it probably falls into the cracks between either side taking any responsibility.

Mmm… The 1248 doesn’t have the direct monitoring feature available in Cubase, is it right? So, it’s normal that the issue is gone.