Direct monitoring UR28m input3/4 external instrument

Hi All,.

I know this has been posted before in other threads, but None of them got any response. So that’s why a new attempt to draw your attention to the following

I’m using the steinberg UR28m with Cubase7. I have an external instrument set up in VST Connections and routed back to inputs 3/4 of the UR unit.

Big question: How do I get the setup into direct monitoring of the external instrument?.
If not possible, please let me know than i do not have to search any further :wink:

You’ll need to set the output mode to “Independent” instead of the default “Alternate” in the control panel.

I’m using the UR824 and don’t have that option. My only options are “Buffer Size”, “Device Attenuation”, “Power Management”, “Clock Source”, and “Direct Monitoring”. You’d think that checking “Direct Monitoring” would do this, but all it does it let you use Direct Monitoring (instead of looping through Cubase) when using the monitor button…

Any ideas for us UR824 users? Can I listen to my keyboard without having a channel set up in Cubase?

3.png
2.png
You have this option in the dspMixFx_UR28M control panel and in Cubase. See the attached screenshots.

P.S.
Sorry, you are talking about the UR824. When I read through the manual it looks like, it even has no control panel :frowning:
1.png

This is what mine looks like - I do not have your options…
Screen Shot 2014-01-01 at 7.53.15 PM.png
Screen Shot 2014-01-01 at 7.53.15 PM.png
I’ve had my post up for a week, tried on other forums too and nobody has any answers. I’m going to have to return this unit - what a disaster.

In addition to this problem, it is so inconsistent. Worst is when I quit Cubase I need to restart my computer to get DspMixFx back.
Screen Shot 2014-01-01 at 8.16.01 PM.png

I have the same issues with different hardware. The ADM works great on all audio channels; however, I use external midi drums for beats etc. The return busses do not work with the ADM. I can’t find any info in the manuals, regarding direct monitoring capabilities of CB7.5.

The other issue I have is that when it is an external instrument in a vst track (as the manual suggests) the output to the stereo out, can’t be shut off, so I get the annoying latency issues when I over ride the direct monitoring in my interface mixer.

The ideal thing for me, and a lot of others I’m sure, would to have the monitor button turn off the stereo out for the VST track and turn on the ADM for the return buss (analog audio at the physical input). Then when you want to track with the external instrument sounds, you stand a chance of actually being in sync with your material.

Maybe I’m dreaming
Any help would be greatly appreciated.
if this is the wrong forum please advise.

PS
I went back to my old school method, removed all external instruments and created two tracks, one = MIDI receiving data from instrument and, two = audio from the instrument. Both tracks get recorded on the same pass. Therefore, I get both worlds. Don’t need em, but hay if it ain’t broke… :mrgreen: