Disable/Enable VSTi track causes MIDI input "not connected"

Anyone else experiencing this? I was setting up a big template with the AWESOME new capability CP8 has of disabling Instrument tracks. The problem I found is, if you re-enable the track after closing and re-opening the project, the MIDI input sets itself to “not connected”.
You have to close the project after disabling the track and then re-open the project for the bug to happen. If you simply disable/reenable the track without closing the session, the MIDI input is ok.

This is a small thorn in an otherwise great feature as you have to select “all midi” for the input after enabling any Instrument track in your template.

Any workarounds for this? I was hoping it would be fixed in 8.0.20, but no such luck.

Sorry to be there bearer of bad news… Known for a while, and we are still waiting on a fix.

http://www.steinberg.net/forums/viewtopic.php?f=230&t=72239&p=416533#p416533
http://www.steinberg.net/forums/viewtopic.php?f=231&t=71825&p=414489#p414489

Please dont forget that it also looses expression maps sometimes!