Disable jumping to the next page during note input

Hello! I tried searching but did not find anything for this specific issue.

Dorico jumps to the next page when the last bar of a staff has been filled in on the current page. I think this is because it is following the caret as it moves to the next note position to prepare for the next note.

The caret moving is fine in and of itself (and I actually prefer that), but I’d like to prevent the view from automatically following the caret to the next page because I input notes for each full page at a time, rather than one instrument at a time.

Does Dorico support this yet? The equivalent option in Sibelius is to disable “follow caret” to the next page when inputting notes.

You’d probably prefer to work in Galley view rather than Page view.

Thanks Janus. Not quite, I like working with one full page at a time. But if this setting isn’t available in Dorico yet, it’s not a big deal… more of a small nuisance than anything else.

Dorico does indeed not currently have that option, and it’s unlikely we’ll be adding it imminently, but I know it could be useful for some people so I certainly don’t rule it out for the future.

Thanks Daniel. Do you prefer people to open a feature request, or is this something you just make a note about internally?

There’s no more formal way to make a feature request than simply to post here on the forum.

In the meantime, one thing I noticed that can serve as a workaround: if you’re in Page View and the screen is more or less centered on a page boundary (see attached), the caret will still jump but the view will not. The view only seems to jump if the following page is not already part of the screen view.