Disable mouse input

Disable mouse input doesn’t seem to stick in D3.
Fine on mac, but windows 10 ignores it.

Sorry you are having this problem, but I do not experience it on my Windows 10 machine.


FWIW it seems to work fine for me on Windows 10 as well.

It certainly sticks OFF in D3 - I don’t think I have had mouse input enabled since Dorico 1.0.

I remember Steve Parker asked once about editing configuration files and the difference between the “default” file and the “current user copy” which have the same name but are in different directories.

I just wonder if the warning “don’t edit the default files otherwise things may go wrong when you upgrade” has kicked in, and somehow Dorico 3 is reading its initial configuration from one file, but storing the updates made In Edit Preferences in a different one - and is therefore “losing” the update with you close and restart it.

Good spot Rob, but this is on a new windows machine that is as downloaded. The preference sticks off but in write mode clicking adds notes.

So even with the select tool (the pointer icon in the Notes toolbox on the left-hand side in Write mode) illuminated, you see the shadow note when hovering over the music and can input notes in the score? Can you make and attach a short screen capture? Be sure to include the whole screen.

I can confirm this behaviour

Lucas, your screenshot doesn’t confirm anything, only that you have the preference turned off. All that option does is set the default state of the selection tool (the arrow) in the toolbox when Dorico opens a project. If the selection tool is switched off, you can input notes with the mouse, even if the preference is turned off.

OK, I think I didn’t understand how it worked. I understood the behaviour after reading the documentation, if the “Select” tool is activated, you cannot input notes with the mouse. The preference as it is now is a bit confusing to me, because if I disable it, I expect that mouse input is actually disabled right now, and not as the default behaviour when I open or create a project. Besides, the name of the tool “Select” is also confusing to me, because according to the documentation, its sole function is to allow or disallow note input. Then, why is it “select”? Maybe it should be something that shows clearly that when activated means mouse input active.
Anyway, it’s all clear now for me, and it works as expected on my mac. Thanks!

Thank you Daniel. I didn’t know that the preference wasn’t a disable always button. I must have hit the select tool off at some point. What does switching the select off allow?

Sorry if this sounds like a stupid answer, but switching the select tool off allows you to input notes with the mouse :slight_smile:

Clearly not stupid. Thank you!