Disable the Audio Engine?

Is it possible to launch Dorico Pro 3.5 without the Audio Engine?

Perhaps a command-line entry or a configuration file modification ?

I just loaded Dorico for the first time and it will not start properly. Dorico startup seems to be hanging on issues related to the Audio Engine. If I could get it to come up without the sound that would be a good work-around until we get Dorico to start properly. I really need to do some typesetting.

I just bought the product two days ago and have trying to get it started.

…john

Perhaps if you try to open one of the files that people have shared on the forum, it might open properly. Most files shared here have the “silence” template applied. Ie- just click on the dorico file to get the program to boot. I’m not sure that will work, but it’s worth a shot.

Also, I presume you’re on windows, in which case perhaps downloading the asio4all firmware might help.

John, are you Windows or Mac?

It would certainly be helpful if you could post some pertinent logs here for the team to assist you. Audio is quite a challenge since so many systems are different, but @Ulf is the resident genius around here.

If you’re on Windows, open Task Manager, scroll down to find VST Audio Engine, and force it to close. If you’re on Mac… I have no idea, sorry…

Windows 10 Enterprise, version 21H1, installed 7/15/20, build 19043.1415, feature pack 120.2212.3920.0
i7-4790K, 32GB, 64 bit

I will try that again. I did not get the app to load, it just errored out.

Thank everyone. I will try all of the suggestions.

1 Like

Hi @john505, sorry to hear about your trouble.
Since you can’t let generate a diagnostics report, please do one manually by doing:

  1. Open File Explorer and in the address bar type: %APPDATA%\Roaming\Steinberg
  2. In that folder, zip everything up with Dorico in the name (should be actually only 2 folders)
  3. Go to your Documents folder and in there to the folder Steinberg/Crashes
  4. Zip up everything in that folder as well.
  5. Send the lot to ‘u dot stoermer at steinberg dot de’

I’m 100% sure we’ll get you up and running.

Ulf,
It’s almost 10 pm!
Best customer service ever

3 Likes

Thank you for your suggestions.
I tried clicking on a Dorico Example Projects, but Dorico behaved the same way and didn’t start up fully.
I downloaded and installed the asio4all driver. I was able to see the driver it in another program, but again, Dorico did not start up far enough to select the driver in Dorico.
…john

Thank you for your response… I have sent the files per your request.
… john

Wave Audio applications/licensing seem to be (at least) an issue.

Apparently my wife installed something that uses/used Wave Audio applications. I deleted everything I can find on the system including in regedit that relates to Wave Audio.

But, now when I try and start VSTAudioEngine3.exe it complains that Wave Audio doesn’t exist. I don’t know why the Dorico VST is including Wave Audio elements, but it does seem to be a key to getting Dorico to start.

*** run VSTAudioEngine3.exe ***
–errors in no particular order over many repetitions–
“Initializing: Finish scanning VST3 Plugins…”
“Waves License Error”
“No Valid Waves licenses Found”
and a few others related to Waves, or Waves Central.

…john

That’s a known issue. Even though uninstalling WaveShell, there still remains some part on your machine and that then triggers these error/warning messages during audio engine start up.
But usually that is only a warning message. If you click it away, the audio engine shall still run as normal.
And don’t wonder that after the splash screen it just goes away. The audio engine is supposed to be a headless background process.

Dorico Pro 3.5
Advanced Music Notation System
“Audio Engine Process Died”

– I’ll wait and see–
It is not responding to a click yet.

…john

But can you see the VSTAudioEngine process in the Task Manager?

To follow up on this thread, it turned out to be like this: John is not on a normal Windows but some server edition. On launch Dorico starts the Synsopos process (copy protection related) and the audio engine process which in turn tries also to connect to the Synsopos, but in John’s case this failed, thus the audio engine hanging and Dorico recognizing this as a dead process. So in the end everything is stuck, nothing is moving anymore.
The solution was to start Dorico with administrator rights and everything is fine.

3 Likes

And now you’re updating this status on a Sunday afternoon! How could the other companies even try to compete?

6 Likes

Many thanks to all of you in the forum!

A special thanks to Ulf !!!

Ulf has been professional, helpful, and knowledgeable. His willingness to go way beyond the norm has saved me so very much time.

…john
Ventura County, California, USA

5 Likes

Hi Ulf I’m experiencing the “audio engine process died” on starting up Dorico 3.5 Pro. My problem began when I tried to install Dorico 4.0 on a mid 2010 MacPro. I can only use High Sierra on my system and I believe Dorico 4.0 requires Mac OS 10.15, which I can not install on my system. I have tried trashing the 3.5 app, the 3.5 audio engine in the library preference folder and reinstalling 3.5. but I still get “audio engine process died” on the start up There is no trace of Dorico 4.0 on my system that I’m aware of.

I expect Ulf is already asleep, but if you zip up the Dorico 3.5 AudioEngine folder from /Users/your-username/Library/Preferences and attach it here, I expect Ulf will be able to take a look tomorrow or on Monday and provide some hints.

Great thanks, Ulf, here is the zip file for 3.5 audio engine
Dorico 3.5 AudioEngine.zip (13.2 KB)

Hi @aa12tone , this is a strange one. First thing, open Activity Monitor and see if there is some VSTAudioEngine process still running. If there is, kill that one and try again to launch D3.5.
There are only 2 logs of the audio engine and both break off immediately after launching, which suggests that the engine was crashing. Therefore, please open the Console application and on the left of that window choose the CrashReports tab. Then have a look for anything VSTAudioEngine related. Click an highlight one of them, do a right click and choose ‘Reveal in Finder’. Then zip up everything VSTAudioEngine related and post here. Thanks

Hi Ulf thanks for your help. I’m not too familiar with Console, but I was able to find a couple things related to VST in the “Mac Analytics Data” tab. please let me know if they are helpful or if I didn’t get you the information you had asked for.
DiagnosticMessages.zip (2.4 MB)