Disable time stretch algorithm automatically when at original tempo

I often use time stretch on audio tracks when temporarily slowing down the tempo to input MIDI notes in cases where I’m not capable of accurately performing a part in real time (I do this by toggling the tempo track on/off). Before I do this, I have place the audio parts into “Musical Mode” in the pool. But when I toggle back to the original tempo, I can hear audio artifacts (especially on high pitched instruments). Turning “Musical Mode” off for those audio parts removes the artifacts. It would be extremely helpful if Cubase would automatically disable the time stretching algorithm when playing back at original tempo.