Disabling a track erases assigned MIDI routing. Any alternative options or a solution?

The other posts on here are suggesting that it is a bug? Is this true? I am on the latest version of Cubase Pro 12 on a Mac. The MIDI routing changes to something random and every time I enable the track again, I also have to reroute the MIDI track to the correct channel. If it’s not a bug, then is there any other ways to save RAM? Will Freezing a track do the same thing?

I also try selecting all in hopes of batch editing the routing, but it doesn’t work. Is there a way to select and batch edit (this is pretty common in other DAWs)?

Hi,

Could you please describe your use case exactly step by step?

Hi Martin,

Thank you so much for your reply. I’m just setting up an instance of komplete kontrol with Kontakt 7 mult out in it and 16 midi channels controlling each instrument inside . Each Midi channel is also routed to its own audio channel. Set up works fine before disabling. Disabling the instrument track and reenabling it again makes me lose all the MIDI routing in the MIDI channel source I created (not the channel number). It goes to a random track and I have to reroute everything individually - that’s why I also asked about selecting and rerouting tracks all together instead of individually going to every single channel. Usually other DAW;s have this where you want to rename or edit something - all you have to do is select multiple things and edit.

Thank you so much!

Hi,

Can you reproduce this with NI Kontakt/Komplete only or with and Instrument, please?

Hi Martin,

I had to delete my reply to you and repost again because I noticed a few things.

I have updated to the latest version 12.0.52 on a Mac (Intel)

-Problem happens when there are multiple instrument tracks of ANY plugin (not just Kontakt).
-It doesn’t happen when there is only one instance of an instrument track
-Deleting the Cubase 12 file in my preferences didn’t do anything.
-Updating to the latest version didn’t do anything
-Rerouting the MIDI source on my midi tracks don’t make it work either. I have to delete the VST instrument track and remake it for it to recognize (even after rerouting) to play the sound
-Problem happens in ANY project (empty or full)

I’d really love to disable tracks as it helps me save CPU. This function is one of the big reasons why I decided to use Cubase as other daws aren’t the same.