Disappearing CD/DVD burner bug back again?

Just did it. This solved the problem. Thank you!

Philippe, while I was experimenting yesterday with uninstalling/installing, registry checking etc. as described in my post, I did not see your reply. It’s always a good idea to listen to the developer himself… :grinning: What lead to success was to install the driver separately after the update to 10.0.50. Now everything is up and running.

Thank you very much for your great work. For editing and mastering classical recordings, WL is the best and most complete solution I know.

1 Like

This burner-recognition failure is really an inexcusable in a $500 program. I fixed the problem caused by the WL Pro demo with the software “solution” posted, but I find it absurd that I had to do anything at all.

I take that back – I thought the “fix” worked, but I only got burner recognition back after I uninstalled WL Pro.

2 Likes

thank you !!! installing this recovered my cd drive ! you guys need to put this download in a place where it can be found easier ! i had to go tru alot to find it ! thank you !

i just installed version 10.0.60, and yes i checked immediately; my dvd burner is back again!

so it is really wavelab related. i ‘refused’ do to the fix, because it always comes back with a next update… (i don’t burn a lot, so, but mounting iso’s, for Native Acces, can’t be done, can still install them, but Native Access takes it’s time… that they can’t be installed, use winrar for it…)

windows 10 pro (20H2 up-to-date), wavelab pro 10

more people mention this. it is even on an info page on the steinberg site. so? what is happening.

beside this problem, great program. something is done, when wavelab installs, what? i am tired of troubleshooting (owning a lot, so more bugs…).

and why does it alternates???

The CD driver of WaveLab is a shared resource. I mean, other software could change the registry and affect the driver, because they install some other similar driver, for example.
Once the WaveLab driver is installed, WaveLab will never touch it anymore, but to use it (“read-only”). This means, if the driver installation is changed, this is by some process external to WaveLab, out of the control of WaveLab.

ok.

but why, when nothing else changed, and the dvd burner wasn’t there, that after i installed wavelab 10.0.6, the dvd burner was immediately visible in explorer again, without restart.

and when i installed 10.0.5 it was gone, it began with 10.0.30, installing 10.0.4 fixed it, 10.0.5 dvd burner again gone.

it can be conflict, with native access? it daemon driver is always loaded i think. but i had NI before wavelab…

it is strange, the correlation is there, but is wavelab the cause, or is it a combination.

i noticed that at some point, no dvd burner. but that Native Access could mount an iso. after i fired up wavelab 10.0.05, there was another update, that didn’t work anymore, mounting iso’s, didn’t work.

if you see the posts, some people experience really this problem, and it is related to wavelab in someway.

before i had wavelab, i never experienced the disapparence of my dvd burner…

you mention the wavelab driver, wavelab does install a cd driver?

because it is shared experience, on windows 10 (perhaps also win 7), what causes it?

the relation can’t be denied, that does not mean wavelab is the cause, per se.

thanks for answering, by the way.

it isa strange problem.

1 Like

Why on Earth is Wavelab THE only produkt messing up the CD/DVD drives?
My drives work flawlessly in other software, including Cubase. Wavelab doesn’t even see my drives. Don’t tell med this is not a bug, because it is!

The CD drivers are external to WaveLab. If another application modifies the registry in certain areas, then the CD might disappear. This is not a bug of WaveLab. This is an external action upon which WaveLab has no control.
Usually, just reinstalling the drivers is sufficient.
http://www.gearsoftware.com/support/drivers.php

Sorry. This is not the fact. Why do other programs see my drives? I have at least 15 programs that are using my drives, and no other program has problems with the drives. It has been like this for many, many Wavelab versions. Reinstalling the drivers you are linking to does not do the trick.
Why do Cubase see my drives? Cubase is also a Steinberg product, and …well?

1 Like

indeed, the repeating answer is: another application, why is it when i installed the latest version, my cd/dvd burner was back again. after the installation… it alternates… i saw 10.0.7 is coming, i guess, my cd/dvd burner will disappear again. from windows (10).

when it happens, no other programs are installed together with wavelab…

and i had never before, this problem, until i bought wavelabe pro 10… and at that time it is version 10.0.20, it happened with, 10.0.30, 10.0.40 solved it, 10.0.50 problem back, installing 10.0.60 immediate acces to my cd/dvd burner… so no reinstalling of drivers, but installing an update of wavelab solved it. so how can an update solve this problem, if it is unrelated to wavelab…

i can set my windows in debugging mode? deep dive into windows, for this?
those days are over, for me.

wavelab is developed on a mac? i am sure there are beta/alpha testers, for both OS… i hope…

(and again beside this fact, it is a fact, investing in wavelab pro 10, even in sale, was worth ir, more than worth it, i repeat this; i even pulled out the real power of it, not necessary, it becomes necessary… i pulled out enough for me, already.)

1 Like

@PG1
and yes! it happened again, i attach two screenschots, of the file explorer, the first shows my burner, the second not.

what changed in between; only installing wavelab 10.0.70. alternating, again…

it has to do with wavelab or a conflict, nothing between those screenshots changed, only the update the newest version, as mentioned.

A problem has been identified with the antivirus ESET.
But maybe other anti-virus too.
You could try this:

  • Open the Run dialog box by pressing the Windows logo key and R simultaneously.
  • Enter the following string in the newly opened Run dialog box:
    regedit
    Click OK or press Enter.

*Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

  • Double-click the entry “Upperfilters”.
  • A new window opens showing values in one or more lines.

If the contents is different than a single line with the text:

GEARAspiWDM

Then remove all lines and have the single one:

GEARAspiWDM

  • Restart your computer.

Maybe you get an error message after rebooting… in which case, just reinstall WaveLab 10.0.70

1 Like

thanks! i use Avast… normally i always disable the shields when installing, it mangles installers; or better not all get installed right. (for example Arturia… and other brands, but many ‘small’ developers…).

can’t remember if i disabled it. but shall check it out, if this is the conflict, and the solution, than i am happy.

Avast was the cause of a major problem, in the past. troubleshooting for a week… only deinstalling Avast, worked. now… if something is wrong…

again, thanks, and if this fixes it, it is finally no longer a problem.

(virus scanners these days are quite aggresive…)

I have used Eset antivirus for many years now, and have never had the CD writer problem (nor any other problem relatable to the AV).

Paul

i went into the register, not unknown territory…, the contents was the single line. so this does not help, because, it is already the line that must be there.

so for clarity; value of Upperfilters is: GEARAspiWDM

is and was…