disappearing chords

I am just working on a musical and have to write the chord symbols for the comping musician.
I work with galley view when I input the notes, chords and lyrics a.s.o. and now and then chords are simply not displayed after I have input them. When I switch to page view I can normally see them correctly but not in galley view. However I have also experienced this the other way round.
When I close the project and reopen it, all is there.
Strange bug.

Here are two screenshots where a part is visible. But more often the chord symbol is completely invisible in one view.
Bildschirmfoto 2018-03-30 um 23.23.32.png
Bildschirmfoto 2018-03-30 um 23.23.21.png

I’ve seen this behaviour too. I don’t have a solution but I’d be very happy to dig out a file that has this problem if the team are having difficulties reproducing it in-house.

Yes, we will certainly require one or more projects that exhibits this problem if we are to investigate it.

Harrumph. The project that was displaying this problem 48 hours ago now isn’t. That could be for any or all of the following three reasons:

  1. I’ve deleted a whole batch of chord symbols and tried re-entering them (and they’re now working just fine).
  2. I was on a Windows machine and am now trying on my mac.
  3. I was playing chord symbols straight in via MIDI keyboard and am now just typing them in on a regular Qwerty keyboard.

I’ll have to have another look when I’m in my office (spare/box room!) in the next couple of days, unless ReRei gets something over to you first.

I had the same problem, but it sort of seems to be solving itself. I’ts like there’s a glitch, but when I restart the program the chords are there.

There have been known cases in which Dorico needs to be restarted to update its graphic presentation fully. The Team is aware of at least some of these incidents.

I have this problem in every project.
Chords with slash notation sometimes only show the bass (even when the root is not a repetition). Sometimes the whole symbol doesn’t show for the upper staff while it’s in all other staves.
I can’t find how this bug is “ruled” as it seems to be random.

Still having problem with chord symbols that don’t show.

Ex:
I input a few chords on empty measures showing full rest. Once in a while, the symbol doesn’t appear. If I input a note below the “hidden” chord, the chord appears. I then delete the note and the chord symbol keep showing. (wich is a workable workaround but still very annoying)

My gut is telling me this is all related to differences I have noticed in Galley View vs. Page View - with things not showing in Galley View. If things look fine in Page View, but go missing in Galley View, that is the issue that needs to be sorted out by the developers. (It’s “there”, but not showing because space has not been made for it). Check this out (especially words in bold):

Chords also disappear in page view. So it seems to be a display bug.
They reappear when i close the file and reopen it.

Did anyone find a solution to this problem? I’m having the same issue - some (not all) slash chords showing only the slash and bass. Nothing I do - closing, restarting Dorico, changing fonts - has fixed it. This is a fairly big problem for me as I have an assignment coming up in a few weeks …

Just for extra detail, the chord in question is a G/D. If I change it to, say, an F/D it displays properly. And not all G/D chords are affected.

Peter, welcome to the forum.
Is your G/D preceded by another G chord? If so, that’s an Engraving Option, not a bug…

Bless you, you’re a saint. That has solved the problem. Thank you!

Don’t know if this particular thread is still open, many apologies if not. But if it is, I have pinned down some behavior concerning the disappearing slash chord phenom. These are observations I have made, and may not be the same for every user?

  1. If the slash chord in question is not in “the default chord symbol appearance” project default list, it displays correctly. If it is in that list, it does not display at all.

  2. Also, if I edit the slash chord as a single override, the edited version shows up correctly in the score, but with the root and quality present.
    In other words, the edited single override chord shows up as Cm/Bb and not /Bb. If I try to upgrade the chord to a default project status, it disappears completely, just as before.

Not sure if listing symptoms is any help for a diagnosis in this case, but it’s worth a try?