Disk Cache Maxing Out - Audio Dropouts

Hi, I’m currently working on a project and I’m having some issues with the audio dropping out on a few tracks and my Disk Cache maxing out. It seems a bit weird that it’s doing this because my PC has fairly decent specs and the project isn’t crammed full of VSTs… I recently tried to optimize my PC for music production using this guide - https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/optimizing-windows-for-daws.html because my CPU meter in Cubase has always maxed out with what i feel is very little going on in the project in terms of what my PC should be able to handle, but I reverted the settings back to how they were because I noticed little difference, apart from a louder PC… (If it’s of any help, I disabled Hyperthreading, Speedstep and C-State to no avail).

My PC specs are:

Windows 7 64 bit
Intel Core i7 870 @2.93GHz
8GB Ram
1 500GB HDD
1 1TB HDD (Dedicated to my audio files and projects) - I think both my HDDs run at 7200RPM

Soundcard: Focusrite Scarlett 8i6 - I’m using the Focusrite driver, pretty sure it’s the latest update. I’ve also got my buffer length set to 19ms, which is pretty much as far as I can go on the settings.

My DAW and Project specs:

Cubase 7.5.20 64 bit
Project that I’m having problems in has 54 Tracks.
-4 cases of Steinberg’s Compressor
-11 cases of Fabfilter’s Pro-C
-9 cases of Fabfilter’s Pro-Q
-3 cases of Fabfilter’s Saturn
-5 cases of Fabfilter’s Simplon
-1 case of FM8
-1 case of Groove Agent SE
-1 case of Izotope’s Nectar 2
-1 case of Steinberg’s Magneto II
-3 cases of Massive
-2 cases of Steinberg’s Multiband Compressor
-1 case of Steinberg’s REVelation
-1 cases of Steinberg’s Roomworks
-1 case of Voxengo SPAN
-1 case of Rob Papen’s SubBoomBass
-3 cases of D16’s Toraverb
&-1 case of Sugarbyte’s WOW2 filter

I did have a few other things running with some CPU intensive stuff like Kontakt and Guitar Rig, but I bounced these down to audio. That bought my CPU down to about 50% when idle, but didn’t affect my Disk Cache readings or the audio dropouts.

I did also notice my sample rate was set to 88200 in my driver settings, I tried to see if changing it to 44100 would make a difference, but Cubase crashes before I can finish converting my audio files.

Also, I dunno if this makes any difference, but I’ve had my PC since about 2010 and I’ve never connected it to the internet, just to be safe. Would there maybe be some Windows updates that I need that could be affecting this?

Any help would be greatly appreciated.

Since the disk cache is maxing out, chances are rather high that the vsti’s are not the cuplrits for the dropouts.
Also, since you froze the kontakt’s there is even less going on on the cpu front.
But i guess there are a very high number of audio tracks recorded here.
Working with a higher buffer setting seems logical here, but you probably have that one maxed out also ?

kind regards,

Yeah, I’ve come to the conclusion it’s nothing to do with the VSTs because I bypassed all of them and it was still the same.

Could it be something to do with the fact that my sound card sample rate is set to 88200 for the project? All the audio files I’m using are 44100 and have been converted in the project… Could this be causing the disk cache to max out? I’m not even sure why it’s been set at 88200…

most likly. It looks like you’re facing the maximum capacity off your hard drives. Reducing the sample rate will definitly reduce the payload on the disk drive, but you wrote that changing the projects default rate crashes the project during the conversion so that makes things a bit more complicated…
You could try to make a backup of the entire thing so that you have every sample organised in your folder and then batch convert them. THen reload the project, that will indicate when initializing the samples found are not 88Khz (anymore), and then choosee not to convert them, and then change the project’s default rate to 44,1 f.e. It 's a bit dirty and trying to get a workaround, but it could result to an converted project.

kind regards,

Yeah, looks like that’s what I’m gonna have to do. I’ve never used the batch export function, does it allow you to bounce each track separately to audio in one go? Gonna be a bit annoying because I don’t want to commit some tracks to audio yet, but guess I’ve got no choice!!

Thanks for the help :slight_smile:

Try defragmenting your hdd’s

I had a similar problem a while back. I started having problems at 96/32 when I got to about 65 tracks. Printing vsti instruments to audio will make your problem worse, not better. Your asio meter shows how hard the computer is working to generate audio (e.g., converting vstis to sound, using plug-ins to process sound, etc.) while the disk cache meter shows how much data is streaming between Cubase and your HDDs through the serial ATA ports (Sata). The limit is based on the type of drive and the serial ata port configuration on your motherboard. HDDs have a limit as to how much data they can read or write at one time, and SATA ports come in different speeds as well. The actual speed will be the lower of either your HDDs or your motherboard sata ports. Sata 1 was about 1.5gb/s, sata 2 around 3gb/s and the new sata 3 is about 6gb/s. So even if you have HDDS that offer sata 3 speed, if your motherboard only supports sata 2, your limit is 3gb/s. More audio tracks at higher sample rates tax the bandwidth of the sata ports and the read/write speeds of the drive. If you switch to Sata 3 (and especially to SSDs on Sata 3) you will greatly increase your system’s ability to run more channels, up to the limit of your cpu.
If your asio meter is peaking out, you print vstis to audio or freeze tracks to fix the problem. If your disc cache is peaking, and you’ve adjusted the preload to optimal and you still have the problem, you have no choice but to reduce the number of tracks or the sample rate. I suggest you do some creative bouncing (e.g., submixing 8 BG Vox tracks to one stereo pair).

I also had this issue a few weeks ago - decided to do a complete rebuild of my PC - the issue has since gone away. it was very strange. Touch wood Cubase 7.5 has been 100% solid since.

I also still have the same issue in 7.5.20


Did anyone find the cause of this problem?

I rebuilt my PC from scratch so never really got to the bottom of it. I actually think it was related to not having Intel Rapid Storage Technology installed. I’m running on W8.1 with no disk overloads. Not sure but worth a try?

I think for me, it was the fact that my projects were being defaulted to 88.2 instead of 44.1. For some reason, I can’t change the default on my soundcard settings, but ever since I’ve been making sure my projects are set at 44.1, they’ve been running a lot smoother.

It’s driving me nuts… can’t work on anything

I posted more details - http://www.steinberg.net/forums/viewtopic.php?f=181&t=74978

It’s just started doing it suddenly.

Hello, I had a similar problem and I think I found something that solves this, at least partly.

As it turns out, Windows has something called DCOM enabled by default. It stands for “Distributed COM” which enables other computers on the network access COM objects on your Windows. I encountered other threads, not audio-related, but hard-disk related, suggesting to disable DCOM entirely to make the hard-disk stop read/write peaks. This feature is not really necessary in a DAW either way.

So I followed this and disabled DCOM:

And I ran a session which would previously dropout and it was MUCH better. I still had some issues with the disk, but I think they are related to other things that are not optimized well on my system.

Would be happy to hear if this works for you!