Display chords on a voice sheet : bug due to multi-measure rest?

I have setup a score with voices, instruments and rhytmic instruments. The chords are displayed on the rythmic instruments first. I have to change this in the ‘lead player’ and set ‘Show for all instruments’. So far so good: on the lead player there are chords now.
The first 4 bars of the lead sheet is empty. There are only chords in the first 3 measures. The 4th measure don’t have a chord. Dorico places a 1 above the measure from the multi-measure rest. Is this a bug?

Not a bug. If you don’t like the default behaviour, go to Engraving Options (Ctrl-Shift-E or Cmd-Shift-E), Rests section, then scroll down to the Multi-bar Rests section and fiddle with the two settings regarding “single bar rests”.