Distributing midi: notes go to random channels

I’m trying to distribute notes of a four-part ensemble into seperate midi channels. I’ve followed the instructions step by step in the manual and got it to work, partially that is.
As you can see in the screenshot the notes are randomly assigned to a channel, instead of top line to Channel 1, 2nd line to Channel 2 and so on. for clarification: Red is channel 1, Pink channel 2, Brown channel 3 and Green channel 4. In this example channel 4 is the only one that’s correct, but in other attempts channel 4 was also all over the place.

Either Cubase interprets things wrong, or something in my settings is incorrect. Is there a way to get this to work as I want it to?
random midi.PNG

Hi,

Could you link to the step by step instructions you have followed, please?

To me it seems the MIDI Notes are not quantised. Therefore for example the very 1st bar… It seems the G2 is at very 1st position. It’s the only one note at the given time, therefore it has been marked as voice 1 = channel 1. Then C3 is coming, therefore it’s voice 2 = channel 2.

It’s just an assumption (guess), so am I wrong?

Hi,

Thanks for replying so fast.
Here’s the link to the manual: https://steinberg.help/cubase_pro/v10.5/en/cubase_nuendo/topics/note_expression/note_expression_notes_to_different_channels_distributing_t.html?hl=distribute%2Cnotes

I’ve quantized a new one, but there’s no difference

Hi,

Thank you for the link.

This is not distribution to the channels in terms of voicing. From this function you cannot expect you would get channel 1 for the melody and channel 4 for the bass. This is more called as Channel Rotation. So Cubase just go through the MIDI Data. Takes the very 1st MIDI Note and assign MIDI Channel 1. Takes the 2nd Note. If the MIDI Channel 1 is still occupied (while the MIDI Note with MIDI Channel 1 is still On), assigns MIDI Channel 2. Takes MIDI Note 3. If MIDI Channel 1 is occupied and MIDI Channel 2 is occupied it assigns MIDI Channel 3. If MIDI Channel 1 would be free already (so the MIDI Note with Channel 1 would be Off already), it would assign MIDI Channel 1.

From the MIDI specification, the MIDI Notes are scanned from the bottom. This is why MIDI Note G2 is taken as the 1st Note to check, when all 3 MIDI Notes share the same Start Time.

What would probably fit better to your use case would be MIDI Logical Editor > Musical Context > Select Highest Pitch. You could adapt this to set Channel 1 to the Highest Pitch:
Channel | Set to fixed value | 1

Transform

Or you can prepare 4 Logical Editors and change the 2nd condition:
Context Variable | Equal | Note Number in Chord | 0
=> Channel | Set to fixed value | 1

Context Variable | Equal | Note Number in Chord | 1
=> Channel | Set to fixed value | 2

I hope this helps.

Also, in case it is interesting, there’s another way to get SATB voices the OP mentions.

You can use the Score Editor Explode function (best to do it in Edit mode, not Page, and you don’t even have to look at the notes).

Open the score editor
Open Score Settings
Nav to tab Staff>Polyphonic
Activate Polyphonic in the dropdown menu
Select Explode from the Scores>Functions menu
Config: (how I set it up)

To Polyphonic Voices
Lines to Tracks (weirdly named, yes)
Bass to lowest voice

The default will give you four voices, and the voices will be channelized so:
Ch voice
1 S
2 A
3 T
4 B

You might have to clean things up a bit, especially if there’s cross-voicing, but it works pretty well.

Thanks, this might be what I’m looking for.
I can get Cubase to record outgoing midi, but only with looped instruments, not played notes in string patches f.e.