Dled and installed trial and can't submit code due to error

I downloaded the trial, used the Dorico WIP to install, and everything went smoothly. However, when I click on the desktop shortcut it made, I get an error message that reads:

“An error has been signaled by the Protected Object Server:
File SYNSOACC.DLL could not be located in the Windows system folders.”

If I click out of the error, it pops up again (this happens two consecutive times). Once that’s done, a window pops up saying:

“No license was found. Click Enter Activation Code to launch eLicenser Control Center and enter your activation code.”

I do that, and the previous error message appears again. I have no idea what this file is for or why I don’t have it on my computer if it’s important enough to stop the program from loading.

Yes, that file is essential, without it you won’t get Dorico to work at all. Try reinstalling the whole program.

Per your tip I’ve now tried to uninstall and reinstall multiple times, but I still get the same error message.

EDIT: Wait, it’s doing a new installation that looks more proper now. This didn’t happen before. Will check back with results.

EDIT2: Everything’s working fine now. Thanks!