Does automation suck, or am I just hopelessly incompetent

I had a home project filled with automation (“75 tracks”, some with up to 4 or 5 automation lanes), and last night I needed to insert 16 bars of silence in a section of the project where there happened to be a lot of automation changes.

After inserting silence, the second part of the project (the one to the right of the inserted bars) sounded horrible.

It seemed that in the left-most 16 bars of the tracks pushed to the right by the inserted silence, almost all but not all of the automation appropriately traveled with their displaced events; unfortunately some of that automation remained in the same place, and was not moved to the right by the inserted silence. That’s why the results sounded horrible.

This was reliably reproducible, automation on the same tracks being the culprit each time. There were no locked tracks, visible or in folders. And indeed, “Automation follows events” is preferenced to “on”.

After hours of failing to individually manually drag the automation on each of those stubborn tracks to the right just exactly the correct amount, I gave up and Rendered-in-Place each of those tracks instead.

As i was going through all this I was reminded of the words of an acquaintance who has made his living using Cubase for decades, who firmly believes automation is “unreliably fiddly”, and he has somehow accordingly adjusted his workflow to avoid it as much as possible.

I’m beginning to wonder, is he right? Alternatively (and not mutually exclusive) if the buggy behavior is actually between my ears rather than in Cubase/my system … well that would be a drag, but I can live with it, I’ll keep on trying anyway. Just wish that didn’t have such a negative impact on sleep hygeine! :smile:

Can anyone tell me please what I might have done differently to deal with, or ideally avoid dealing with, that stubborn, immobile automation?

Thank you!

C12.0.30 Pro, W10

(I can make a vid if my description isn’t clear enough).

Hmm, I’ve never come across that problem and I must have inserted silence hundreds of times. I don’t think you’re hopelessly incompetent, but there may be something unusual about those tracks. Can you think of anything that makes them different from other tracks?


Thank you for your reply, @RichardTownsend !

I truly am stumped, and am just about ready to say the universe just doesn’t want me to use that Cubase function, there must be a good reason, ha!

Maybe you or someone will see something helpful in the vid if you have a moment to look.

Thanks again!

I also quite often use the insert silence option but never seen this behavior before. Did you maybe switch from ’ Initial Value to Virgin Territory automation’ somewhere during the project? Not that this would validate such behavior, but it would maybe explain why this happens? Also have you tried a complete restart of your computer? Some people keep their computers running for weeks in a row without ever restarting. A simple restart can sometimes solve a lot of these ‘unexplained’ issues.

I can agree with your acquaintance. Cubase can be “unreliably fiddly” not only considering automation but as a whole. :slight_smile: Sometimes we just have to deal with stuff like this and find a solution for it to work.

Personally, I would not be happy with this behavior also but I would just move (cut/paste) the automation manually and be done with it and consider it as an isolated incident. But It could also be an issue with your system (video driver)? You can check by inserting a ‘midi monitor’ plugin on the track to see if the values that were left actually output the values after the insert silence? If not? It’s a definitely a display issue.

It also just might be a temporary issue with this specific project? If you start to notice this more often on other projects as well it might be a serious bug that needs to be fixed?

1 Like

You have some hidden tracks - that might be confusing the range selection.

There’s a different (simpler) way of inserting silence that might work.

You don’t need to use the range tool at all. Once you have the locators in the right place you’re all set. Just execute insert silence.

This will insert silence on all tracks.


You can see in the video he just does that. he merely makes the selection to point out the selected area. Whatever you select with the cursor, the inserted silence will always be applied starting at the the left and and ending on the right locator.

1 Like

I could be wrong, but I think that if you select some tracks with the range tool, the insert silence is done on the selected tracks only, whereas if you don’t make a selection with the range tool, it’s done to all tracks.

So even if he is doing the selection just to show us something, it will be affecting the result.

1 Like

Could be. But he’s clearly not specifically selecting the tracks where the issue occurs. Just the selection that affects all the tracks within the left and right locator.

I must say, whenever I will do an ‘insert silence’ I absolutely make sure noting is selected! So who knows? Maybe that’s it?

Thanks, @RichardTownsend and @Nickeldome for taking the time to look !

I unhid all the hidden ones, so all were displayed, unfortunately the same behavior as in video occurred. It also gave me the chance to make sure no tracks, events, or parts were locked.

Odd, when I do that insert silence does not work on any tracks. Maybe I’m not doing it right? I set up locators, make sure it is activated (“purple”), do Edit>Range>Insert Silence. Nothing takes place visually on my screen when I do that.

I think I excluded this, though not sure if there is a way I didn’t, by dragging some audio into the “inserted region” and routing it to one of the groups that had automation that wasn’t shifted. The automation was active.

I did not. I’ve left “Use Virgin Territories” unchecked in the automation panel since a bug was described a few years ago. Just now I checked it and tried to Insert Silence, but also got the same behavior as in my vid.

I can’t recall if I’ve had problems in another project with insert silence, I will check.

If it doesn’t work at all, then something is blocking it. What that is, I don’t know. It would be nice if Cubase said what the problem was.

I Have a vague memory of someone having a similar problem on the forums - have a search!

Do you have any locked events, including old track versions?

1 Like

I manually checked everything, nothing locked (I wish I knew how to create a PLE for an automated search through my project for all locked tracks, track versions, events, parts, and if there is anything else, for those too).

And critically, it’s easy to check that the few tracks where the automation doesn’t move when I attempt to insert silence aren’t locked.

My guess: Something is locked, and I just can’t find it. Uggh.

I remember that the problem last time was to do with folder tracks - check those carefully!

1 Like

Yes sir, thanks, I did for sure, including for the nth time just now.
Here’s how I did checked to make sure no tracks were locked:

I selected all tracks, went to track control settings and made sure “Lock” was in the show column, then hit Z so the lock/unlock icon was visible on each track, then scrolled up and down all tracks to make sure there were no “locked ones” (I guess Group Channels themselves can’t be locked/unlocked, only their automation).

Then in the project itself I did a CTRL-A, then up at the top I clicked Edit - unlock was grayed out, so I assumed there were no locked events, parts, or otherwise.

Just to be sure I did CTRL-A, then Edit>Lock so all the tracks were locked, then Edit>Unlock so they were all unlocked.

No joy though with any of this though.

However, I’m guessing indeed I am missing a locked track somewhere, can’t find it. The sequencer equivalent of looking for my glasses, but I’m actually wearing them, I’m guessing, ha!

All this begs the question - I’m assuming lots of folks who insert silence also have locked tracks in their projects. How do they deal with that - just locate and unlock all, then try to remember which ones to lock when finished inserting silence?

Hmm, try opening all your folders - I think closed folders may not be picked up properly.

Yes, I’ve done this with locked tracks and never had any issues. Insert silence should be brutal between the locators and should not discriminate on whatever status a track has.

Have you tried to insert a midi monitor on your track to rule out it’s a video issue?

1 Like

You have to have the select tool selected (or the combined Mutitool, or whatever it is called), then it will work with locators only.
If you have the range tool selected, insert Silence will “need” a range selected, which seems to be buggy in your Situation.

Hope it helps,


1 Like

I did figure this out just now.

Some Track Versions were locked. When I removed the two tracks that had locked tracks versions, Insert Silence worked as expected, using just the locators, no range tool this time.

@Nickeldome ,

Please correct me if I’m wrong, but I believe I ruled out a video issue by sticking some audio between the locators, routing it to one of the Group Tracks whose automation between the locators would not move to the right when I tried to Insert Silence, and finding that the audio was affected by the visible automation that “didn’t move right”. Would that also be a correct way to rule out a video issue, without needing to insert a midi monitor on the track?

I guess for some reason on my system it appears there is discrimination - something locked will keep insert silence from working here. That makes Insert Silence almost useless for me, as I’ll very often have locked tracks, events, parts, etc., and it takes forever to find where they are so I can remove them, all with the goal of getting Insert Silence to work.

I hope I’m missing something obvious, otherwise I’m very disappointed - I’m always needing to insert silence it seems!

Thanks again, everyone. Any other kind and helpful suggestions are still very much appreciated, if indeed there’s anything left to do :slight_smile:

I don’t think you’re missing anything. I can think of any way round this. The only question I’d ask is. Can you get away with not locking things, or maybe just do it at the track level to make things easier?

1 Like

Thanks much @RichardTownsend

It just seems so weird to me that Case can function so differently on one system vs another (referencing that someone in this thread said locked events don’t prevent Insert Silence from actually inserting silence).

Was hoping maybe someone might recognize this as a Preference issue, alas …

Hmm, I’m not sure if it actually is different on different machines. I’ve heard of locked events causing problems before.