Does Dorico/Nuendo lock the MIDI interface?

On windows, the same as it can do with the audio interface? I’m debugging this issue, it appears that only one application at a time can be using an interface. I need to have Nuendo using some ports and Dorico using others, as specified by the allowed ports in each application.

Can you be more specific? Do you mean that you have both Nuendo and Dorico sending to a third app and what is the MIDI iterface - a virtual one? I don’t want to waste you time with suggestions that don’t apply to you.

Not an expert and taking a blind stab - At one time it wasn’t completely uncommon that I had MIDI going into Dorico and MIDI going into Studio One but I’ve specifically told Dorico and Studio One which virtual MIDI devices to care about. I haven’t done that in a while until rewire support or a similar way of synching comes along that works for me - The issues I recall are the opposite of locking - IE of needing to make sure there isn’t a feedback loop going on that locks up the virtual device.

Thanks gbdball


It’s like this. I’m seeing that ‘Interface’ gets locked by one application and none other can use it, but I want them both to be using it with Port1 being used by Dorico and Port2 being used by Nuendo

Okay, so in my world there isn’t a shared interface exactly if I’m using two keyboards. My Keystation Pro for example shows up as its own MIDI device and I only enable it in one of the applications. The only other keyboard I have currently is kinda worthless, but if I used it it would show up as a separate device like nanoKey or something and I would only enable it for either Dorico or Studio One…

I more often use LoopBe30, and I might create maybe 4 virtual devices using that. I may specifically enable only one of those devices for input and send the others from Dorico to Studio One as Output. It would look something like:

Keyboard → Keystation Pro Driver → Dorico
NanoKey → NanoKey Driver → StudioOne
MidiGuitar → Virtual Device 1 → Dorcio
Dorico → Virtual Device 2 → Studio One
Dorico → Virtual Device 3 → Studio One
Dorico → Virtual Device 4 → Studio One

I don’t enable ANY of them for Thru, or for output from Studio One because of feedback issues. I don’t use the MIDI capabilities of my Audio interface either. Speaking only of my own pain - apparent locking has been because of creating a MIDI feedback loop of some kind.

In my experience some MIDI drivers do not support multi-clients, and some do.

I.E. I have an AKAI MPK261. The first app that grabs it takes exclusive control.

When I wish to use it with multiple hosts, or otherwise route it about my system I use loopMIDI to set up a virtual port, and run something like Bidule or Bome first to take the MPK2, and send to one of those virtual ports. Since the virtual port is definitely multi-client friendly, I can use that to get the output of my MPK2 from any app running under the same user account at will.

An added benefit to the setup is that I can make my MPK2 a lot smarter through Bidule or Bome…transform things on the fly, set up zones, multi-channel layers, enhanced arps, and a whole lot more.

It’s worse than that, I put one of the keyboards on a different MIDI interface, but whichever app gets started first locks all the interfaces, preventing the other app from getting any input.

Really, Windows? This can’t be right, surely I can use multiple apps accessing MIDI on Windows simultaneously, what am I doing wrong?

What is the MIDI Thru capability in this context? When you check “MIDI Through” for Dorico preferences, what does that do?

The App won’t/can’t grab it if you tell it not to in its preferences. In both Dorico and Studio One, I tell which ones to pay attention to and which to avoid. I would look for a solution there first. I am running Windows 10 as well, so, I would hesitate to focus there just yet.

MIDI through lets you chain devices - effectively sending the same MIDI input to several destinations but it can get you in trouble with not just looping but synching. I’m not saying don’t use it, I’m saying turn it off if you aren’t using it and it removes a potential source of problems.

Yeah Dorico is set to ignore interface A, Nuendo is set to ignore interface B. So A should play on Nuendo and B should play in Dorico, but that’s not what I’m getting. Whichever app is started first grabs exclusive access to all MIDI.


If you do not wish to use an intermediary app like Bidule or Bome, you could just have loopMIDI (or some other virtual port option) and use empty MIDI tracks, with the monitor button active, in Cubase to route things around through these ‘virtual cables’ to other apps and/or devices.

Thanks, I didn’t know Windows forces exclusive access to MIDI, this is so incredibly stupid. One thumbs up for OS X, if they only weren’t going down the dark side. I’ll look into these other options.

That’s not a ‘Windows’ thing. It’s a driver thing. It’s more common in USB <> MIDI drivers.

My AKAI stuff isn’t multi-client friendly, but my M-Audio, Tascam, Roland and Yamaha gear has no problems with multi-client support. They all came with ‘better drivers’.

Some kit might come with a driver that allows one to disable exclusive mode. Have a peek in your “Device Manager” control panel in case yours has check boxes and ‘options’ to try out.
Click your start icon and type “Device Manager”, open that and have a peek.

Quick example:

Without Bidule or Bome:

  1. Setup up a virtual MIDI port. You could use loopMIDI (free, very nice, unlimited number of ports, easy to add/remove them at will), loopBE, MIDIyolk, whatever).

  2. Launch Cubase first and let it have control of everything.
    Make an empty MIDI Track, set its input to which ever keyboard you wish to route to Dorico. Set it’s output to your virtual port. Set the channel to ANY if you’d like to do channel changes via the keyboard, or if you want a hard channel routing choose the channel you prefer.

If you have multiple controllers (more than one keyboard, wind jammers, etc), make more empty MIDI tracks like above to what ever you want via virtual ports.

Toggle the monitor button for the track ON.

If these ‘routing tracks’ are in your way, you can stash them in a folder and ‘hide’ it out of the way until you need to see it again.

  1. Launch Dorico.
    By default it’ll hear anything coming through ports it can access on launch. Your virtual port should be connected already. If you like, you can open Dorico’s preferences and mute out anything showing up that you’d like it to ignore.

With Bidule or Bome (both have free to use demos that would fit the bill for simple routing):

  1. Set up some virtual ports and give them nice names if possible (You can name them with loopMIDI).

  2. Run Bidule or Bome FIRST, and set it up to grab your MIDI device(s) as input, and use your virtual port(s) as output. With Bidule, you’d only need one instance and you could route as many incoming MIDI devices as you like anywhere you want it to go via the virtual ports. With Bome, you’ll most likely want a fresh instance for each controller device you’ll be using. Again, you’d have it grab the device(s), do its processing (optional), and route it on to a virtual port.

  3. Have Cubase and Dorico listen to the appropriate virtual port(s).

Brian, thanks so much now it’s perfectly cleared up.

Fortunately, I have the ESI M8U eX 16 port USB 3 interface, which works with the generic Windows driver. However I remembered ESI does have an optional driver, and upon installing that I’ve got unlocked technology!

I can’t recommend this interface enough. And whatever you do avoid the MOTU Midi interfaces. I got the MIDI Express XT, and at one point my Windows computers refused to sleep, instead doing a hard shutdown. Traced it to this interface. MOTU replicated the issue, but now six months later refuses to fix it. The driver is from 2013! Go with the ESI, which in the 21st century is also updated with USB3.0.

Until it stopped working … but this time I could switch over to another interface (so two keyboards on different interfaces) and that does work. Chaos! Weird things going on … no, that turned out to be an odd Nuendo problem. It won’t accept input directly from that port, but “All MIDI Input” is OK.

Ouch, I feel the pain. Every time I plug in something ‘different’ it always comes with yet another learning curve and ‘work-around’ solutions.

I almost forgot to add that some drivers add options to the Windows control panel as well.
Might check that out just in case. I usually go to the old legacy UI for it since I’m most familiar with it.

Click Windows start icon, type in Control Panel and run that. Look closely just in case some of your MIDI gear has added control panels with extra ‘options’.

I notice in my case some stuff for my Roland XR, Tascam US-1200, and Delta 1010 interfaces.