Does Melodyne 5 and RX8 work as an External Editor in WL11?

Melodyne seems perhaps a bad idea here but I’m wondering if anyone has found a way to use it in WL? Then RX8, which quickly sees the file from WL11 and performs an Edit in RX8 but will not return the rendered file. Is this also a bad idea? Has anyone sorted this? It did work in WL10…

I have had success in WL10 and WL11 using RX8 as WaveLab’s external editor to sent small pieces of audio from the Audio Montage to RX, make an RX edit, save and close the file in RX and when I return to WaveLab, the fixed section is now in place in the Audio Montage.

I have never tried anything related to Melodyne and WaveLab. It seems that ARA2 support would be needed for that to make any sense.

I’ll try the Save and Close in RX8. Thanks. In RX what throws me is that in Cubase you can return the edited file via a right click on the header of the edited file (that says “Return to Cubase”). This header is still there but it does not say “Return to WL”. Interesting.

I think the answer for me is to spend more time in WL and not as much as I do in Cubase. They have obviously similar ‘mechanisms’ but the keyboard shortcuts for one is far removed from the other. IMO, it’s too bad the two products can’t find more common ground. Oh well, they are both brilliant programs. Thanks again, Justin!

Are you using RX Connect when doing this with Cubase? With WaveLab, it’s much more direct and RX Connect is not needed.

In Cubase, yes, RX Connect. In WL I just added RX8 as an Extension Editor. I’ll try what you suggested a little later, Justin. I am burnt out right now having sat here with WL11 for the past 6 hrs…

BTW, I think I saw where someone had a problem with a Waves plugin and PG said he was going to address this. In my case, I’ve also had a strange things happen. I put the Wells Centric Mixer plugin on a track and then removed it. Later as I went to render the two tracks (Montage), WL sent a message that Wells Centric was having a serious problem and I should save my work. And of course this WL message froze WL and the option to save anything. But after a few minutes I was able to play the two tracks and turn this message off. And at this point WL seemed fine and never crashed, but it was odd that it seemed to think I still had the Wells plugin loaded.

Do you use Waves and have you had any issues? My experience with Cubase and WL is that the newer versions needs a little time to settle in.

And now that I think about it, I put the iZotope Imager 2 plugin up on another track slot and it wouldn’t display the usual GUI image of dispersed audio, but instead only showed the stripped down plugin control panel. Weird. I thought maybe it was the slot so I tried something else and the visual GUI was correct. BTW, I did try the Imager that is in Ozone 9 and it displayed properly. This could be on iZotope, I’ll check it out tomorrow.

Thank you for getting back to me on this, Justin. I imagine you are spending some time with WL 11 right now, as well. All the Best.

Yes, I think adding RX as an external editor to WaveLab is the fastest and best way. No need to use the clumsy RX Connect app. Just select an area, press a shortcut to open a copy of that section in RX, WaveLab will focus RX for you, make the RX edit(s), Save & Close the file in RX and when you go back to WaveLab, the fixed version is automatically there.

I can’t think of any Waves plugins I still use other than the Dorrough Meters if I’m working on my laptop but they seem to work. PG might have to speak about the channel error message as I only work in stereo and don’t use any multi-channel FX or configurations.

Regarding iZotope, I just opened the VST3 Imager that comes with Ozone 9 Advanced and it works OK here in the Montage Output and Clip FX.

Ozone 9 Advanced has not been updated since May 14th 2020 and only lists WaveLab 9 as being supported.

RX hasn’t been updated in awhile either.

I’m not sure what’s going on with iZotope and the lack of updates but I would ask them when they plan to officially support WaveLab 11, or even 10.

When you say “stripped down control panel”. Do you mean a generic grey GUI? If that’s the case, somehow this plugin might have gotten set to GEN (Generic Mode) in the Plugin Settings in the WaveLab Preferences. If you see the GEN box checked for this plugin, uncheck it.

Jason, you were right about the Imager 2 being checked in the wrong box. I unchecked it and it works as it should. Thanks.

This said, the RX8 is still not working correctly. I have tried what you suggested, ‘Save’ the edit, but it does not transfer the clip back to WL11. Oddly enough when I’ve completed the edit in RX8, the image of the edit in RX8 is rather ‘grayed’ out (color of the wave file is not vibrant), as if the edit is not complete? If there’s something else that you are doing that I am not doing, please let me know. Meanwhile, I’m going to check in with iZotope and see what they suggest. And you are right, iZotope has rather gone down a rabbit hole of late, getting into the ‘rent the software’ business plan and not updating their software. What a shame. I’ll let you know what I learn.

The system works like this:

  • WaveLab creates a temporary file out of the WaveLab’s audio selection, and opens this file inside RX (or whatever external editor).
  • Then WaveLab watches for this file to be updated (that is, you saving the edited file in RX)
  • When this happens, WaveLab reintegrates the temporary file inside the WaveLab editor or montage.

Does that shed some light on your case?

1 Like

I work a few years with RX 7 and 8 and it works very fine with Wavelab 10 and 11.
No need to use Connect. In Wavelab. It works faster as Justin described.

1 Like

Thanks for the replies gentlemen. The issue I’m having is caused by the inability of RX8 to actually ‘Save’ the altered clip - the ‘Save’ option in the pulldown window is greyed out, not an option. And as a result, the clip cannot be sent back to WL.

OK, so I took a look at the audio driver setup in RX8, in my program. When I first installed RX8, it automatically chose the MME Win10 driver and routed this to my Mackie outputs. I found this odd but it worked, I saw no harm in this. Looking at the available drivers in RX8, it lists only two: the MME and a Generic ASIO. It does not list my Mackie ASIO driver which I can’t understand. Years ago using RX5, etc. it was there. What are you guys using? Is RX8 finding your sound device’s ASIO drivers or are you also using this ‘Generic ASIO driver’?

Anyway, switching to this Generic ASIO driver allowed me to SAVE the sound clip and this was what I was missing. The altered sound clip is now sent back to the WL Project. I will assume it is some strange ASIO to ASIO communication that needs to happen here in WL. In Cubase, using the MME driver and the RX repair options there, things worked. Now I will see what happens in Cubase since I changed to the Generic ASIO driver.

Pretty weird, as audio device drivers and audio files are meant to be separated, system-wise.
But at least you have a solution.

I will have to check tomorrow when I’m back at a computer but in RX, you may want “Overwrite Original File” rather than Save. I have so many shortcuts and muscle memory involved I might not be saying it 100% correct but it should be possible.

The ‘Generic ASIO Driver’ is the one supplied by Steinberg, FWIW. Cubase is not working in regards to sending a clip to be altered in RX8 and then back to Cubase using this driver. BTW, I misspoke here earlier, the Cubase to WL and the return trip works exactly as it should - I forgot to set the clip rendering to ‘edit in place’. Arrg, sorry!

I’ve sent an email to iZotope trying to figure out why RX8 does not find my Mackie ASIO driver and also that I’m having issues with using it as an external editor in Cubase.

So, Q: Those of you that are using RX8 (as an extended editor from WL), are you using the same ASIO driver in both programs? Does RX8 still find the ASIO driver of your interface or does it use the Steinberg Generic driver that I am forced to use?

Justin, as you suggested, using the ‘overwrite original file’ was the solution to using RX8 in WaveLab as an external editor. Thank you for being so helpful here. I really appreciate you taking a minute to write your response - it’s likely I never would have tried this, Justin.

So I guess no one here is using the RX Monitor option in Cubase? It certainly doesn’t work for me as it sits. Then I guess I’m set. I still would like to know what driver you guys are finding in RX8 though…

1 Like

Hi mr Roos
In RX 8 the program has in my situation choosen for the MME driver. When I try to set it to my RME driver there is no signal.
However it works in this setting, but it is strange isn’t it ?

I have spent some more time to find a solution. Now I could chose the ASIO driver and specific my RME dirver and could choose in the channel routing the right outputs. So I work now with RX 8 and ASIO.
With Ctrl Alt S I can overwrite the original file. (That was possible too with the MME setting)