Does this tempo track bug exist in Cubase Pro 10?

There’s a tempo track bug in Cubase Pro 9.5, and I’d like to know if it has been fixed in Cubase Pro 10. I asked Steinberg to fix this bug several months ago, but they replied that Cubase was not designed to work the way I’m using it. However, I’m just following the instructions in the manual, which I found under the heading, “Deleting Data in Selection Ranges”.

If you want to see the bug in action, watch this video:
https://www.youtube.com/watch?v=mS8WBji77X0

To learn more, scroll down to the red text in my fourth post.

You don’t state what Timebase the track(s) are in. Are they set to in Musical or Linear Timebase?

Deleted, to avoid confusion.

Forgive me if I’ve missed this in the original post, but did you check the files in the Project Audio Pool?

I don’t know if this will “solve” this, but – as you likely know – the files in the Audio Pool also have some settings that might make this work, or work-around better. Not sure.

I’ve not hit this bug. I’d like to know if this is a so-called “known issue” or is it in fact an instance where the Operations Manual needs a usage note or edit?

I’ve not tried to replicate your detailed steps but will have a look at that when time permits. So, for now, I can’t answer your basic question as to if this issue (assuming it is one) still exists in Pro 10.

Thanks for the post.

I can’t really give you a full answer here- this is a complex workflow you have presented.

I recall the difficulty I had in getting my head around how timebase and audio files in musical mode interact.

My suggestion would simply be to read the manual chapter on each, and verify that you completely understand, so you can use them to your advantage.

There is no bug that is being reported here.

Steve, in the first line of the Op’s post he calls this a “bug.” :slight_smile:

I’ll try to replicate his steps and see what I find. I’ve not had any problems with Tempo Track and Tempo Changes.

Please read the rest of the thread, he was doing it wrong.

Deleted, to avoid confusion.

Timebase is a track property, not a Project setting.

With due respect, it is possible that problem lay in your understanding of the functions. A track set to linear timebase will not sync with the tempo track, that’s the point of having it. Musical timebase syncs to the tempo, and linear does not.

@-Steve-

It was with my audio track set to Musical Timebase that I initially experienced the problem. I switched to Linear today only because I thought you were implying that I should try that. My mistake.

In fact, Steinberg tech support was able to replicate this problem in January. The tech contacted the Steinberg developers about it, but they claimed that Cubase was not designed to work the way I’m using it. However, I’m just following the instructions in the manual, under the heading, “Deleting Data in Selection Ranges”. The same instructions are printed in every manual from version 7.5 through version 10.

The malfunction does exist in Cubase Pro 9.5.50, as you can see for yourself in this video:
https://www.youtube.com/watch?v=mS8WBji77X0

I would like to know whether the problem has been fixed in Cubase Pro 10.

If anyone has 5 or 10 minutes to spare, please try the following simple steps in Cubase 10, and see if you can replicate the problem:

  1. Create a test project.
  2. Create an audio track.
  3. Put about 5 minutes of audio on the track.
  4. Set the timebase to Musical, both in the Track Inspector, and in the lower pane waveform editor.
  5. Select the audio event, and then select Musical Mode in the Info line.
  6. Split the audio into at least 10 adjacent audio events.
  7. Create a tempo track.
  8. Create a fairly drastic tempo change at the start of each event. Play the audio, to verify that the tempo track works.
  9. Put one tempo change exactly at the right edge of the final audio event, so that you can see if it stays in sync after steps 12 and 14 in this procedure.
  10. Put a Marker at that location too. (You need to create a Marker track first.)
  11. Using the Range Selection Tool, select a range across the first 2 or 3 audio events that you created, ideally where the tempos are extremely fast OR extremely slow. In your Range selection, include the marker track and the tempo track. No snap is necessary.
  12. From the Edit>Range menu, select Delete time. Is the final marker or tempo change now out of sync with the audio?
  13. Undo step 12.
  14. Then, from the Edit>Range menu, select Insert Silence. Is the final marker or tempo change now out of sync with the audio?

If you don’t mind taking 10 minutes to try this, please post your results. I would like to know whether the bug has been fixed in Cubase 10 Pro.


If you encounter problems, and feel like trying the workaround, here it is:

After you select the time range that you want to delete (Step 11):
i) Press P to set the locators to that range.
ii) Next, switch to the Object Selection tool.
Then from the Edit>Range menu, either Cut Time or Delete time. Is the final marker or tempo change now out of sync?

I’m using the workaround these days, but it’s easy to forget the two extra steps and not realize that the subsequent tempo changes are now out of sync. To avoid this risk, I might consider upgrading to version 10, if it doesn’t have the bug. So I’d like to know, has this bug been fixed in Cubase Pro 10? Please post your results.

Thanks.

Bump: Can someone please check to see if this bug exists in Cubase Pro 10? It does exist in version 9.5, and has been replicated by Steinberg tech support.

To test version 10, just follow the procedure highlighted in blue in my previous post. It will take only 5 or 10 minutes of your time. Please post your results to let everyone know whether the bug still exists in version 10.

Many thanks!

Just down load the demo and try it for yourself

Indeed, this.

Good idea, but that’s not possible at present: The Cubase demo requires a Cubase dongle, and my Cubase dongle is on the other side of the planet.

Meanwhile, I’m considering purchasing the Cubase Pro 10 upgrade during the Cubase anniversary sale, but only if the tempo track bug has been fixed in Cubase 10. I won’t be able to test this myself until after the Cubase sale ends, because I won’t have access to my dongle until then.

That’s why I’m asking for help with this.

If you ever need to apply tempo changes to audio, as I do, this bug should concern you. So please test my procedure and post your results. It will take only a few minutes. (The test procedure is highlighted in blue text. Scroll up four posts to see it.)

Thanks.

Yes the bug still exists in 10.

Actually, I can reproduce it in version 8.0.40 too.
And it’s not specific to audio; I can use a midi track and get the same error.
It seems the Marker track position is not correctly calculated.

But here’s the thing - it only happens when you use the range tool to define what you want deleting/inserting. If you use the left and right locators, it works as espected - no error. Given that Tempo Tracks are global - you can only have one of them per project - it makes sense to do a global delete/insert when required, otherwise certain tracks will get out of sync with the Tempo Track.

If you really need to only delete/insert on particular tracks, lock those you don’t want to process, and use the left & right locators globally instead of the range tool.

Thanks for checking this @TeeJee.

I agree. And my audio tracks end up out of sync too.

Your observation is consistent with the workaround I mentioned above, which was suggested by the Steinberg support tech I spoke to in January.

Good idea.

Actually, I normally prefer to “cut time” at zero crossings. However, the “snap to zero crossings” button only works with the Range Selection tool, afaik. So I do this:

i) Enable snap to zero crossings.
ii) Make a selection with the Range Selection tool.
iii) Press P to set the Locators to the current range.
iv) Switch to the Object Selection tool.
v) Cut time or delete time.

This is consistent with your observation that the time to be cut must be marked by the Locators.

Also @TeeJee, when inserting silence, did using the Locators allow you to maintain the correct sync across the tempo track, audio track, and marker track? (Edit>Range menu>Insert Silence)

Thanks.

Yes.