Dongle broken


I have just purcased Cubase 6 about to weeks ago and had no problems untill today.

I did a reboot of my PC and now i cant acces the dongle and Cubase 6. Windows 7 reports a code 43.

My question is if my dongle is broken?

Windows 7 64-bit, 4 Gb ram, Saffire Pro 24 DSP, Amd Phenom II 2800 Ghz

Any help is appriciated, thx

Does your ‘device manager’ show the dongle? If not then try removing and replacing - does the system recognise that any device is being removed/replaced?

Perhaps it is the Syncrosoft software? You could try reinstalling it? First, does it work when you run it?

What does cubase say when you attempt to run it?

My system repports the dongle as unknown usb device.

I have tried removing it and insert in another usb slots and windows repport a damaged or not known usb thingy.

I got it to read it once right now after replacing the dongle 3-4 times. But if i restart my pc its the same. Really anoys me this copy protection.


Ok, i did a clean-up elicensor and did a reeboot without any problems.

Not sure it did the trick, but im really not comfortable with this dongle i have.

edit 1:

Still dosnt work. But now my windows at least can see the dongle, but elicensor hangs when trying to read the dongle in control center.

Have tried to reinstall elicensor, but no luck.

edit 2:

So things seems to work now, hope it stays that way. I used many hours trying to figure out what was/is wrong but i couldnt identify the problem. I have updated my bios just in case and i will return for assistance if problems come back.