Dongle failing on new MacPro

I’ve just purchased a 2013 Mac Pro (cylinder), which has the 4 USB3 ports.

My license dongle has been regularly failing on that system, whether I connect it directly to USB3 or via a Belkin hub.

I sent a suport request to Steinber yesterday, but no response.

So, I’m going to try it on my MacBook, which has USB2 ports.

Anyone seen similar?

:confused:

I think the dongle doesn’t like USB3 ports. I had a similar issue on a Windows PC with both USB3 & USB2 ports, only worked on the USB2 ports.

Hmmm. That’s not good, considering that the new Macs and many computers these days are USB3 only.

I’d like Steinberg to get back to me on this one.

I have a similar computer but I connect my dongle via the USB ports on the Apple wired keyboard without issue. Assuming you don’t want to change your keyboard, have you tried using a passive USB hub connected to the Mac Pro?

Aloha C,

How old is yer dongle?

I ask because I had a similar prob here with a
new MacBookPro laptop and a dongle that was at least a year or more old.

I use this ax live on stage, which means that I am
plugging and unplugging the dongle quite a bit each week.

Seems the connection would be lost if I moved the dongle
just the slightest amount.
And In that setting that type of behavior could be disastrous.

So I,

1-Ordered a new blank replacement dongle.
2-Made the transfer.
3-The new dongle now ‘sits more tightly’ in the USB 3 port and
all seems well (so far).

As of yet no connections lost.

Good Luck!
{’-’}

It’s a few years old, but of the latest type I know of.

I removed the hub completely last night and plugged keyboard/mouse and eLicenser directly into the Max.

That seems to have worked. Seems like having the Belkin hub itself may have caused some problems.

I do need more USB though. Will have to consider Thunderbolt USB expansion.

No problems here on an iMac with USB 3.
I plug the dongle directly in and run everything else from a powered D-Link hub, model DUB-H7.
The dongle does work on this particular powered hub too just for info.
Unfortunately this does mean yet another power supply of course!

No problem here with the latest Mac Pro. I have had both a Steinberg dongle and an iLok plugged into the USB ports for a year now without incident. Actually I’d avoid using a hub for the dongles, and also suggest that you consider your problem may also be an indication that your dongle is starting to fail. The latter has been suggested numerous times previously.

Glad you got t sorted.
{’-’}

Thanks for the responses.

Out of interest, is anyone using the dongle on a hub?

If so, which model?