"Dont ask again"

Hi all,
Since I have been using Cubase (from LE4 to CBpro 8), when I open the programme after listening to some of the recording using the windows audio, I used to have a message which asked if I wanted to change the audio driver to Steinberg Asio (my CI1 interface).
Stupidly, I checked the “Don’t ask again” box so I now have to remember to change the drivers, as opposed to having the programme prompt me.
I know its a piffleing issue in the great scheme of things, but I cant find out how to change it back to show the original message and thus give me a nudge ( something that is necessary at my age)!!
I have searched the forum but couldn’t find what I wanted unless I trash the pref’s, but I am concerned that if I do that I will loose a lot of my personal settings, so does any one have an answer?
Thanks in advance.

Jim B

I woke up with a massive headache (ongoing) so i will try to give you a little help before i refrain from trying to think or answer any more Qs today…

Cant you just go to the settings (vst audio system or so) and tick “release asio driver in background” so you dont need to use windows audio?

Again, sry if i am of no help… Maybe tomorrow;)

Surely someone else knows it off the bat if the above solution is not viable for your needs.

Good luck:)

Hi guys,

Firstly, thanks GGC, for your suggestion. Unfortunately it didn’t work, so I am still looking to revert back to the “picking my audio device” screen as it was before I stupidly checked “do not ask again” :blush: !!!

Any one got any ideas? Maybe someone from Steinberg could offer me a solution?

Thanks and regards,

Jim B

There is some information about reactivating various Cubase “Please, don’t ask again” options in the Cubase Operation Manual. Try searching there using the words I quoted. Good luck and report back either way. Thanks.

Regards :sunglasses:

I’d like to know how to do this too. I just searched for “Please don’t ask again” and didn’t find the answer.

Hi all,

I have just spent some time searching the operating manual and can confirm that there is no information regarding “please don’t ask again” :frowning:

Anybody got any other ideas because I bet there are more than just 2 of us that want a solution ??

Jim B

This is perhaps #400 in my list of posts which can be boiled down into one sentence:


Cubase does everything except deliver pizza, but this is the kind of detail that can drive one nuts.

Suggestion to SB: Several apps have a dedicated page for resetting all such dialogue boxes in one go. (Adobe comes to mind. I think Wavelab has it as well?)

Most logical place to search for switching on/off this type of confirmation dialogs is the “preferences” section ?

kind regards,

Thanks for the post Suntower,

On the off chance that someone from SB picks this up, here is what happens.
I record some music in my “mancave”, using my CI1 audio interface. If I want to have a listen to what I have done away from the “mancave”, and without having to move my audio interface, when I open the project it seems to automatically change the audio driver to the generic low latency audio driver. All good so far :slight_smile:
When I then go back to the “mancave”, connect my CI1, and open the project Cubase used to ask me if I wanted to change to the Yamaha Steinberg USB ASIO to which I always clicked on yes.
Last week I checked the “don’t ask again” box, because I mistakenly thought that Cubase would automatically swap to the Yamaha Steinberg driver without me having to click anything…wrong!
All that happens now is that Cubase doesn’t ask me anything and I have to go through the process of changing the driver myself.
I know its not a biggie in the great scheme of things but I am at the age where, if I am not prompted, I wont remember :blush:
All I want to do is get back to how it was ( and has been since I started using CB LE4) but I can find no information on how to do this simple thing.
Any help will be greatly appreciated and as Suntower says, after having gone through all the CB manuals (and searching the forums) it would appear to be a failing in the CB programme.

Thanks for your help good people of the forum,

Jim B

Hi Roel,

Thanks for the response.

That was the first place I looked and I have been all through the preferences section (every part of it) and, even though everything else seems to be covered, this issue is not as far as I can see!!!

Of course I may be wrong, and its one of those processes that is hidden behind a lot of other options, but I have not found anything to return this element of CB to how it was.

Jim B


That is an easy fix, you just have to delete the defaults.xml file from the preferences folder.


Best regards,

Hi Jim B… You say that there is no information regarding “please dont ask again” in the manual. Well, when I search the manual for “Please, don’t ask again” I get several hits. To be honest I did not read through them to see if they are related to this particular issue though. Generally, it looks like they are reset by going into various places in preferences.

A couple of suggestions for your consideration:
Maybe hitting one of the “Reset” buttons that are all over the place under “Device Setup” might do something?

Trash your preferences. Not really trashing them but copy them to the desktop then trash and restart Cubase to see if it works. If it does work then decide if it is worth having to reset a bunch of things. If not, then I would just restore them from the desktop.

Like you, I do wish that Steinberg would chime in here to assist. :exclamation:

Good luck. If this ever gets sorted out please post your findings. Thanks.

Regards :sunglasses:

Sb’s GN has answered while you where posting probably. Anyway, if you don’t know how to fix this, as we did, it seems that you can take that warning “never ask me again” pretty serious. The program will certainly never ever ask it again (untill you delete the xml). :slight_smile:

kind regards,

Hi Guillermo,

Thanks for the information, deleting defaults.xml files did the trick :smiley:

Prock, I just did another search on the Cubase Operation manual and came up with no hits???

Anyway, lesson learnt, I wont be checking any “please don’t ask again” boxes!!!

FYI, to find the correct folder I just searched my hard drive for: default.xml and then deleted it!!! How easy was that :laughing:

Thanks again all for your assistance,

Jim B

Glad this is sorted and the information was provided. It is appreciated.

Also… just so the forum knows I am not BS’ing anyone, check op manual pages 250, 446, 515, 1086 for references to “Please, don’t ask again”. :wink:

Regards :sunglasses:

Hi Prock,

Just to clear this up, I was searching for “please dont ask again” as opposed to " please, don’t ask again" and apparently punctuation and grammar is the key :blush:

On my search terms I got nothing, and on the “correct” term I got the ones that you got!!

Another lesson learnt today then, about what I type in the search box for the manuals!!!

Jim B

In a properly indexed manual, this shouldn’t matter.

Also: there is nothing in the doc about his specific problem (bringing back settings.) I also checked the KB and didn’t see anything.

It’s all very well to tell people ‘Google it!’… but that assumes they know the proper search terms.


My god, i almost wrote a book in this thread about “Top secret” audio stuff:p
Had to stop and delete it before i went too far down the rabbit hole:p - a place all too familiar…:stuck_out_tongue:

Anyway, yeah, knowing the “term” of some things helps (if there is one;)) - or good descriptive skills:p

Glad you got it sorted and we now know too (just in case) :wink:

Again, I am just glad you got this sorted and now we all know how to fix it… until we forget and can’t find it when we search in the future because we don’t remember the exact “term” to search. It will happen… guaranteed. :wink:

Also, I agree with Suntower about needing a properly documented and indexed operation manual.

Now for some more babble about the fix…

Glad the fix works but, it is lame. Period!
Having users delete a program file is not “professional” at all. Give me a break. Some users went through this same crap when in CB7 they had to move out all files with the word “video” in it from the Cubase components folder to get CB to stop hanging during startup. Users who did that then had problems upgrading to CB8. Mommalouie!
Sorry but, I am :blush: for Steinberg for these programming issues.

Regards :sunglasses: