Dorico 1.01: instruments play forte and shorten notes

Many thanks to the team for the many fantastic improvements in the update. It is the program for the future.

A problem:
In Dorico 1.0 the playback respected forte, piano, crescendo. (Mostly). If there were too many notes at a time, some of them was omitted. Everything was legato. But you could get some impression of an arrangement.

  1. But in Dorico 1.01 all instruments shorten the notes like some portamento, and often one or more instruments neglects the dynamics and blow a roaring forte. (This is also the case in real life). I have activated default playback template.

  2. Is it possible to stop the playback of a staccato. (I work on a piece from the romantic era, with many staccatos over 1/2 and 1/1 notes. And the staccato is always played very short)

(The strings sound really good - apart from the shortened notes).

To prevent the playback of staccato notes using the short staccato samples, you would need to go to Play > Setup Expression Maps, select the expression map in use (e.g. “HSO Violin Solo” or whatever), choose the “Staccato” entry in the list of playing techniques, and then delete the keyswitch shown in the Actions area of the dialog. This should allow it to still shorten the played duration via MIDI (i.e. reducing the played duration of the note) but without switching to the staccato sound.

I’m not sure what to suggest about your dynamics problem. There are lots of changes to the way dynamics are handled in 1.0.10 since 1.0, but nothing that should prevent dynamics from playing back at all.

Thanks, Daniel. Your advice’s are really appreciated. I now better can hear what’s going on after deleting the staccato entry.

About the dynamics. Paul Walmsley wrote in the update-comment :

“mod-wheel instruments sometimes don’t play back with dynamics if the first dynamic change occurs after the start of the score.”

I tried to set piano-dynamics in the beginning of the score in all parts - without any notes. And now the later entering instruments do not play their lungs out but follow the crescendos and everything. - But after 6 minutes playing the clarinets “forgot” the dynamics. I will try to fiddle with dynamics before their re-entry, or delete some notes and rewrite them ??.

1.0.10 does indeed shorten normal sustain notes too much. Just export a midi file and import it in a DAW (or back into Dorico) and it also becomes visually apparent.

I’ve also found dynamics to be totally unreliable. Some files work, other partly, and some not at all. I’ve yet to discover a pattern…

There are a number of dynamics bugs that have emerged (and some limitations that are intentional, insofar as I haven’t yet written the code to deal with them - eg accents on instruments that use mod wheel dynamics). See my post in the 1.0.10 announcement thread for a few more cases: https://www.steinberg.net/forums/viewtopic.php?f=246&t=106314#p584639

The amount by which you can shorten and lengthen notes for staccato, tenuto, etc is set by an option, but there isn’t yet a UI to change it. It’s one of many things competing for my limited time prior to the next update…

Fully understand that this is work in progress!

Has the issue of note length been fixed in 1.03? I notice that notes don’t play to the end of their value unless you have a slur going to the next note. Is this fixable somewhere that I’m not seeing? I wondered if “playback end offset” could handle this but it doesn’t seem to do so globally, and I can’t find any information for what these numbers mean. Thanks!

Click the play tab, then have a look in the Play Menu at the top of your main Dorico Window. Somewhere in that list under “Playback Options” you should find some Default Playback settings.

You can set things like a Humanizing percentage, The percentage of velocity increase for accents and house tops, the duration of staccato/staccitissmo notes, and the amount of ‘overhang’ that ‘legato’ notes play past the actual note-off event of your score. Notice that by default the normal duration is set to 85%. You might want to increase this to something between 95% and 100%.

In the General MIDI protocol, it’s standard practice to ‘emulate legato’ by holding note 1 in a legato series (notes living under a slur) a little longer, while note 2 simultaneously sounds (a bit of a cross-fade effect).

Some Programs in some VST Plugins don’t like this…particularly if they have ‘low settings’ for the amount of polyphony available for a given loaded instrument. If that’s the case for your Plugin/Instrument, you can remove the default legato overhang in the settings described above.

Also, some Plugins have special abilities to deal with Legato in different ways. I.E. Some might respond to the ‘legato pedeal’ which is CC68 according to the GM Protocols. Some might do it via ‘sustain pedal’ (CC64). Others, might have a special ‘auto-legato’ mode that’ll deal with the ‘overhang approach’ describe above with specialized care. Yet, even more might just give you a range of possible ‘Key-Switched’ layers for legato effects. In most cases like these, you’ll also get some way to induce/remove some amount of portamento in addition to getting that smooth crossfaded effect between a pair of notes living under a slur.

Out of the box, the Halion Symphonic Orchestra (HSO) Solo String Instruments do NOT have a way of properly implementing a specialized crossfaded or portamento inducing legato sound.

In the case of Halion Symphonic Orchestra’s Default “Solo Strings”, I find it’s best to:

  1. Remove the ‘legato technique’ in the expression map. Those key switches are two different/conflicting ‘bowing speeds’. An honest mistake on the part of whomever put that expression map together. Just get rid of the legato technique! It’s actually meant to be an option for bowing at two different speeds, not really as a mid-passage change to ‘legato’.

  2. Increase the number of voices allowed in Halion Sonic (Options Tab) to something pretty high (300 or more).

  3. Allow Dorico to use his defaults for legato (He’ll hang on to legato notes a few ticks, according to the Playback Settings described above).

  4. If voices drop out during playback after having implemented steps 1 - 3, increase the polyphonic voices allowed in HSSE (both in the Macro page of the instrument(s) that are dropping out if possible [number of tone generators allowed by the instrument rack slot], and in the main Options tab of HSSE [Number of tone generators available for the entire plugin]).

If you wish, you can experiment with over-riding the defaults for things like “Accents” by adding new Techniques in the expressionmap for instruments on an independent basis. I.E. Say you want Accents to play 110 percent of the normal attack. I’m not positive if over-riding ‘durations’ in an expression map is functional yet…the few times I tired, my entered values kept resetting to 100%.

It is also possible to replace the HSO Solo Strings with the GM Set from HALion Sonic SE’s (HSSE) Basic Content Library.
Replace them directly in the Instrument Rack of HSSE, and change the Expression Maps to ‘Default’. That’ll give you some dry and clean Solo String sounds (which you can color up with EQ and Insert Effects in the Main Dorico Mixer, and pass onto your Reverb slider via the Aux Bus “Send”). In this scenario, you won’t get Pizzicato and Tremolo sounds in response to such Score Techniques anymore (Possible to kludge them in, but that’s a topic for another thread).

Yes and no. Some bugs were fixed, but the issue is that “normal notes” (hehe) are set to play for 85% of their written duration. For slower tempi and/or longer notevalues this is of course way off. You can change this setting to 100% in Play/Playback Options. You should also set the legato to 100% if you’re using pro libraries that have sampled/scripted legato transitions, such as VSL.

I am trying to get a pp or p playback but everything sounds f most of the time. I adjusted playback options the the Kirk Hunter library settings where ever possible, but no luck till now. Any suggestions?

The settings in KH responds very well to the ModWheel on my keyboard, but do not respond well to ModWheel (CC1) data from Dorico unless you increase the (Play/Placback Options…/Dynamic curve value dramatically. E.g. from 2 to 6…

This can unfortunately present trouble when using different libraries in the same project, as the curve setting is global. (There should really be individual Playback Options for each VST used in the project…)

This is a setting that will in the future be set in every technique of the expression map.