Dorico 1.2 Little bug with filtering voice and scaling

Dear Dorico team,

Amazing update, you have achieved a tremendous work!

I just came across this little bug while using the new scaling function : If I have two voices and want to scale down the second one, I select the area with both voices, filter so that only the second one gets selected, open properties panel, enable scaling — and there lies the bug : only the rests in the second voice remain selected. If I do all those steps again, once the scale property is enabled, I can then proceed as expected.
Here is the video showing those steps.

Hope it helps !
scale (1.8 MB)

This is a long-standing problem whereby any edits you make that cause implicit rests to be turned into explicit ones end up deselecting everything else, and leaving only the newly-created explicit rests created. I’m sure we will fix this in due course. In the meantime, if you don’t want to scale the rests, use the Notes and Chords filter before you set the Scale property.

Actually, I did not even think about scaling (or not) rests, I was just surprised that my selection changed when I enabled the Scale property…