Dorico 2.2 hangs on launch with the audio engine after W10 update

Hi,
It’s probably somewhere on the forum, but I couldn’t findt it an answer;
Audio engine wating for connection.jpg
The Audio Engine hangs and tries to install something but then hangs and I have to shut down dorico and the audio enging with the task manager.
What do I have to do? Cubase has the same error!
Thanks in advance and kind regards;
Herbert

VSTAudioEngine.zip (2.32 KB)
Here is a log file;
Will that help?

As far as I can recall, this one is new. I wonder what the audio engine wants to install there, since the Dorico installer contains everything that is needed.
The log file in this case does not help, as it does not indicate what is about to be installed.
Your screen shot shows that an installer gets prepared, but what is actually happening then? Does that installer also hang?
Could you then go into the Task Manager, find the installer process, right click on it and then choose Properties.
That shows the path to the installer executable and maybe gives us some hint of what is about to be installed.

Also, probably won’t help, but I also would try reinstalling Dorico (just Dorico, not the playback components)
for the unlikely case that the Windows update corrupted somehow the installation.

VSTAudioEngine2.exe is the thing that hangs on install.
And after that Dorico won’t startup either and I have to close it with the task manager

At the first time dorico din’t start up because of the e-licenser; It said having not enough permissions;
But then I did starting the elicenser as administrator and doing a maintenance;

VSTAudioEngine.zip (2.28 KB)
when I start Dorico, I get this log file from Cubase 10

But VSTAudioEngine2 is already installed, otherwise you would not get any audio engine log files.
The ones you posted are actually from the runtime of the audio engine.

But when the audio engine starts up, it must be finding that something is missing and therefore starts another installer.
What it finds missing, I don’t know, that’s what we have to find out.
I guess it must be some Microsoft runtime library, because you say that Cubase shows the same behaviour.

When you get the message as shown in the screenshot you made, what do you do then?
Do you cancel it or let it run through?

I cancel it because it will not go any further;
Then I have to stop the proces of the audio engine and therafter Dorico via the task manager

is it not something yet with the elicenser?

I don’t think it has anything to do with the eLicenser, but you could try running the latest installer from here: https://www.steinberg.net/en/company/technologies/elicenser.html

If that does not fix it, then we need to find out what is actually about to be installed in your case, so please run again Dorico and when that installer screen appears,
please try to find the installer process in the task manager and see what path it gets executed from.

Now I saw something with the yamaha driver;
I have a Steinberg CI2;
What is the newest driver? And can that have something to domwith it?

I have the newest elincenser

The current driver for CI2 is here: https://www.steinberg.net/de/support/downloads_hardware/yamaha_steinberg_usb_driver.html
Please try that one and see how it goes.

Yes, it was the yamaha driver! Now it works again, thank you!
Best, Herbert