Dorico 2.2 not starting because Audio Engine Connection Problem

Hi team @steinberg

I really need your help here, I searched before posting for a solution for this problem, but apparently it didn’t work, I killed the vstaudioengine in the task manager as suggested by some, reinstalled multiple times, but it’s simply not starting whenever I launch Dorico 2.2.

So here I attached two comressed files for you to check (as suggested by one of the employees). As for the operating system, I’m on windows 10.

Please help.
VSTAudioEngine2_64.rar (592 KB)
Dorico 2.rar (9.22 KB)

So the audio engine is crashing during start up for unknown reasons. My assumption is that some dodgy component brings it down.
Please have a look under C:\Users<yourname>\Documents\Steinberg\CrashDumps and see if you can find dump files related to the audio engine. Please zip them up and post here or if it becomes too big, send directly to ‘u dot stoermer at steinberg dot de’. Thanks

Thank you so much for the quick reply Ulf! However, I can’t seem to find any dump files related to the audio engine or anything else, it’s an empty folder.

Honestly, it’s a bit frustrating, I remember everything was smooth with the first Dorico, but then I took a long break from it and once I purchased the 2 and downloaded the 2.2, it never launches from that screen that says “Audio Engine: Waiting for Connection” :frowning:

Please help, everything should be working fine since I also have Cubase 10.5.

In the FAQ thread you’ll find some instructions under ‘Dorico is crashing. What do I do?’ that will help you to set things up so that crash dumps are generated.

Hello Daniel! Thank you for chiming in!

I downloaded that zipped file, installed it like instructed but still didn’t generate any files unfortunately… I tried multiple times now, so here is what’s happening, I click on Dorico 2 to launch it, I get that little screen that says “Audio Engine: Waiting for connection” and then after a few minutes that message becomes “Audio Engine: Timed Out”, makes sense ?..I installed the latest version of the driver for my UAD Apollo Twin interface as I thought the problem was there, but still it didn’t solve anything, still the same messages over and over again, It never opens so I can’t go to the help menu and create a diagnostic report it just stops at that little screen trying to connect to the audio engine or something…

Another thing I tried was launching the vstaudioengine2 alone and first, even that has the same problem, it never starts, it stops at the launch screen saying “Initializing: Finish scanning VST3 Plugins…”

Bear with me, it really is frustrating, so please help me fix it.

It’s weird that you don’t have any crash dumps, but that’s the way it is. Still I believe that a dodgy component is bringing the engine down. Therefore we need to find out which one and the way to do is:

  • Navigate to C:\Program Files\Common Files\
  • In there rename temporarily the folders VST3, VST2 and Steinberg to something else, e.g. add an underscore like _VST3, _VST2, _Steinberg
  • With these folders renamed, launch the audio engine. What is it doing then?

Oh wow! It totally worked after renaming the folders like you said! Thank you so so much for your quick replies and help! Bless you:)

But it’s not the end of the work. Now we know it is some dodgy component that is bringing the audio engine down, but we have to find out which one it is.
First the rough job: Rename the Steinberg folder to it’s original name and start up, and if it runs okay, stop again and rename the VST2 folder to the original name, and similarly with the VST3 folder afterwards. By that we find out, in which group the dodgy component is.
If you find that it is in the VST2 folder, then move all plug-ins out of that folder and play the same game again:
Stop Dorico, add one plug-in to the folder, start Dorico and see if it works, then stop and reiterate.
So you see, it may become quite time consuming, but that’s the way to find the culprit.