Dorico 2 doesn't respond at launch

Could you please provide us the mentioned crash dump (or even several if there are more at that location)?
That would help to make sure it is the same issue or a new one.

Thanks Ulf. I did attach the screen dump but it was stripped off when posted, presumably because it exceeded the size limit.
Here is the screen dump in question:
VSTAudioEngine22.1.0.297 64bit 2018.8.28 22.11.dmp (437 KB)

And here is another one. It also occurred when I opened the Halion SE interface and attempted to make changes for a file created in Dorico 2.0 and automatically converted to Dorico 2.1 pro. I have about 20 more in the same vein.
VSTAudioEngine22.1.0.297 64bit 2018.8.28 22.05.dmp (454 KB)

Further to my last post, to assure myself that I was not dealing with a corruption of the Halion SE program or database, or of Dorico itself, I created a short piece in Dorico 2.1 pro using the same instruments. I included dynamics and articulations, and manipulated the Halion SE interface without problems. All parts played correctly at the correct dynamic level and the program refused to crash no matter what changes I made.

The only possibilities that I believe could have caused the previous crashes are some error in upgrading a piece from 2.0 to 2.1, or some hidden error in the piece itself that was only revealed once it was converted to 2.1.

Any ideas?

Hi David, thanks for the crash dumps and actually it is the exact same issue as Shalendraal (and some others) have. Unfortunately there is nothing you can do about.
Well, for one guy the workaround is using NotePerformer as instrument plug-in and use that as default.
But of course, it shall also work with HALion Sonic SE. We are working on the problem, though it is a really tricky one and we can’t make any estimation when it will get solved.

Thanks Ulf for your reply.

It order to try and get to the bottom of this project I created three files:

  1. An excerpt from an arrangement created in Dorico 2.0 but opened in 2.1. It crashes when I attempt to work with the Halion Sonic SE interface. I notice that Halion contains extra voice assignments but I have no way of knowing if these were in the original.
  2. The same excerpt with the extra channels cleared. It still crashes if I try to change the channel assigned to a voice.
  3. The identical excerpt created from scratch in 2.1. There are no extra voice assignments in Halion, all channels are correctly assigned and it does not crash when I make changes.

Perhaps a comparison of these three would be useful. Here is a link to my OneDrive folder containing a zipped file with all three excerpts:
https://1drv.ms/u/s!AniEEnvPpznJgeM5n3EIHp6fa_kQrw

I hope this will help you find a solution.
Thanks

Sorry, that does not help us, because it is not project related, but many thanks.
However, if you send me a mail to u dot stoermer at steinberg dot de, I can send you instructions and download link to a special HSSE version that has some additional logging.

Some very good news.

I updated Dorico Pro to 2.1.10 and HalionSonic Se3 to version 3.1.15.89 with VST Audio Engine2 version 2.1.10.328. So far there have been no errors and no crashes when I open files that previously caused problems. The files are automatically updated to the latest version.

I did notice that the HalionSonic SE interface no longer opens automatically when I open a file but does open without error when I click on the symbol on the play screen.

I can only presume that some modification in the program solved my problem as well and for that I am very grateful.

I was unaware that there were updates available since other software makes a point of notifying me about updates automatically so I have become complacent about checking. Perhaps you could consider adding such a feature in future.

Many thanks to Ulf Stoermer for all his help in sorting this out.

That’s great news, David. Long may your trouble-free running of Dorico continue!

This happens to me very often on PC, Windows 10. Sometimes I launch Dorico and it’s fine. Other times the exact same files just hang while the blue load graphic sticks at 87%. Sometimes it does open the score window, but then it’s frozen. It’s very annoying. It can happen either launching from the desktop or the hub. When it does happen there is no crash dump. And if I reboot Dorico immediately, the second time it opens correctly.

???

P.S. NotePerformer is my default playback device.

So this happens with projects that exlusively use NotePerformer and no HALion Sonic SE, right?
If that is the case, then it is a different issue.

When Dorico freezes, have a look in the Task Manager and see if the VSTAudioEngine process is running.

Also, please check the folder C:\Users<your user name>\Documents\Steinberg\CrashDumps
Is it really empty? If not, please zip up everything contained and mail to ‘u dot stoermer at steinberg dot de’.

Thank you. Yes, in my case I always use NotePerformer.

There are only 5 crash dumps in the folder, going back to 2017. The latest crash dump is from Sept 29 (see enclosed), but Dorico has frozen many times since then.

Next time it freezes I’ll check the Task Manager. For what it’s worth, my soundcard is the Xonar Audio. However my other music software (Sibelius, Vienna Instruments, Digital Performer) works fine.
VSTAudioEngine22.1.0.297 64bit 2018.9.29 8.27.dmp (474 KB)

What would be useful is that next time you experience this hang, open the task manager and close the Dorico2 and VSTAudioEngine2 processes, then run Dorico again and do Help -> Create Diagnostic Report. This will create a file DoricoDiagnostics.zip on your desktop that includes some logs from the previous run (as well as any recent crashes). This will help us in working out what’s happening on your machine.

It just hung on launch. I restarted it and the diagnostics are included here. I closed Dorico with the Task Manager, but even though I checked carefully there was no process called VSTAudioEngine2.

I hope this helps!

Alan Belkin
Dorico Diagnostics.zip (408 KB)

Firstly I see that you are still running Dorico 2.1. I strongly recommend updating to 2.1.10 as that includes many fixes.

On the occasion where it hangs, I can see that the very last thing it’s doing is activating a plugin from how it was saved last time. It appears to be NotePerformer. I’m not aware of any previously reported problems with NotePerformer hanging. There has just been an update to NotePerformer, so I would suggest updating that and Dorico and try again. If you still have problems then there are other things we can try.

Thank you. :slight_smile: I already updated to the new NotePerformer before the crash today. I just updated Dorico, so I will let you know if and when it hangs again.

I just updated Dorico and it promptly hung, as usual. Here is the latest diagnostic dump.
Dorico Diagnostics.zip (321 KB)

Thanks for the data. Again, the log files look identical.
There are no crash dump files contained in both diagnostic reports, which suggests that Dorico and the audio engine are still running, but deadlocked somehow.

The Windows Task Manager since Win10 does not show reliably the running processes anymore.
Would you please download the Process Explorer (https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer)
and run that one when Dorico seems frozen.
Then right-click on the Dorico and VSTAudioEngine process and choose Create Dump > Create Minidump.
The dump files will give us a better clue of what is happening in the program.

I just started Dorico - it’s running at the moment - and opened Process Explorer. I don’t see Dorico at all. The only process from Steinberg is called SYNSOPOS. ???

2nd try: for some reason, the second time I launched Dorico, now it shows up in the list.

I just had a crash, and created the 2 dump files, together they are about 2 Gig. Where should I send them?