Dorico 2 eLicenser trouble?

Just recently Dorico 2 (whatever is the latest version) often refuses to launch. Dialog says some problem with eLicenser. When I open eLicenser I see all my licenses and the USB stick appears to be fine. I can launch Cubase 9.5 and to my surprise Dorico 1. So far after some fiddling (moving the USB stick to a different port, launching Dorico 1 first and sometimes computer restart) it will work again. I have never seen this before with any Steinberg product and in Dorico 2 only after the last update.

I sometimes have customers over to work together on projects - that error/dialog is so unprofessional.

Any ideas?

Peter

iMac, OSX 10.13

Peter,

This is one of several threads which might help.

For many, the trick is to make sure that the e-Licenser has been launched and is running before starting Dorico.

Thanks for all the help and input. I had most of my new projects started in Dorico 2 over the past year. But I can’t figure out how to reliably run it now. Since the last update to Dorico 2.2.11 1256 It will complain about an eLicenser problem and not start up.

I have tried running the eLicenser before launching Dorico (it’s newest version and it runs the maintenance every time) but it doesn’t make a difference. The only remedy I have found - and it only works sometimes - is starting up Dorico 1 and then leave that running while Dorico 2 is up.

I thought this was a problem with the USB eLicenser but Cubase 9.5 and other Steinberg products work fine.

So right in the middle of two dead-lined projects I will export XML files to Finale and leave Dorico alone until this is solved. Don’t have the time. :frowning:

Peter

iMac, OSX 10.13

Have you tried Mark’s suggestion, above? It certainly fixed my woes…

I have tried it with eLicenser running before I launch Dorico 2. It doesn’t help. At the moment the only thing that sometimes does is launching Dorico 1 before. It seems to me that some software component has to be running for Dorico 2 to communicate with the licenser and maybe Dorico 1 launches that correctly while Dorico 2 doesn’t.

Again, I had never an issue with that before the most recent update so I am hoping the next update will fix it.

I have just had problems with eLicenser and it took a while to go through various options. In the end I downloaded the installer of eLicenser again:
https://www.steinberg.net/en/company/technologies/elicenser.html
After it installed I did the maintenance, then quit it. Dorico still did not open, so I opened it again, then clicked on Dorico and finally it opened. I was ready to restart my computer as a next step but this was not necessary.
Hope you can get some solution (I was not connected to internet at the time I needed to work with Dorico so was very frustrating.)

@Peter, would you please tell us what the exact error message is, that you are getting? Or post a screenshot?