Dorico 2 on Windows 7 (failure)

I have installed Dorico 2 with dongle on my laptop successfully (Win 10 Pro); but when I try to run it on my Desktop (Win 7 Ult 64 bit) Dorico quits with the message “VST Audio Engine has stopped working” (repeated). Dorico 1 still works.
The details are below.


Problem signature:
Problem Event Name: APPCRASH
Application Name: VSTAudioEngine2.exe
Application Version:
Application Timestamp: 5aff73c6
Fault Module Name: VSTAudioEngine2.exe
Fault Module Version:
Fault Module Timestamp: 5aff73c6
Exception Code: c0000005
Exception Offset: 0000000000a8ce59
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 57a7
Additional Information 2: 57a79d9a06bfb4358a29f01312606977
Additional Information 3: b164
Additional Information 4: b164eec68ae77e66dad51d63a832ff71

Please see this thread. The long and the short of it is that you must have the Windows Platform Update installed and you must also be running with Aero switched on.

Thanks Daniel. I turned on Aero, as recommended on the other thread. However, I find the Aero themes quite unacceptable on my computer, which is used for many other purposes than Dorico 2. Choosing Aero also turns on the abominable Windows sounds… Dorico 1.2 runs without Aero.

So, to run Dorico 2, and ONLY Dorico 2, I have to change to Aero on my desktop computer and insert the dongle – which I cannot leave inserted all the time because it prevents the “screensaver” from operating. This is supposed to be a “universal computing machine”!

It doesnt seem right, somehow…


Unfortunately it’s the audio engine that requires Aero, and there’s nothing that we can do about that. Sorry!

Since Dorico was never officially meant to run on Windows 7, it’s on you to decide if you want to go the extra mile to make it happen.
It can be done, which is more than one can expect.

As I dont require audio, can I disconnect it and make Dorico run without Aero?


I find it hard to consider Windows 7 to be the fossi that you imply! It runs everything else that I throw at it and is rock solid (I shall regret writing that!).


Well, Windows 7 itself might be rock solid (my machines have been running it for a long time, too), but it’s other (newer) software that not necessarily runs on Windows 7 because they are based on components (or newer version thereof) that are not available for Windows 7.

I was not aware that Aero mode turned on the Windows sounds, it doesn’t on the Win 7 machines I use, but I specifically turned it off. You can select “No sounds” in the Control Panel>Sound> Sound drop down menu, this menu is also accessible from Personalize>Sounds.

For the screen saver issue, I searched online and found an instructable for making a shortcut for the screensaver on the Win 7 desktop; the file is in C:\Windows\System32 , its called scrnsave.scr , just make a shortcut and stick it on the desktop. You might have to train yourself to use it, but it works ok for me for Dorico and Cubase.


When I went to the control panel applet and selected Aero, it showed at the bottom that Windows sounds have been turned on – and I can hear them; but the option to switch them off is greyed out. Does Dorico really need to rely upon Windows sounds to do its synthesis now? Notice that Dorico 1 does not require Aero, and nor does Dorico 2 on Windows 10.

I may have to change this computer back to Windows 10 again, with its compulsary upgrades.


Upgrades aren’t compulsory in Windows 10 Pro - I don’t know what version you previously had. Might be worth going Pro even if only for that reason.

That’s true. Thanks for the reminder, Leo. I had forgotten it: but I seem to recall that like Skype and Firefox, one is frequently importuned. My laptop is Windows home, but I have a laissez faire attitude about it. (I think I have the only example of Windows 10 in captivity that looks as minimalistic as Windows NT used to!)



When I go to the “Personalize” window, the “Sounds” link is at the bottom, and that takes me to the “Sounds” config window with tabs of “Playback/Recording/Sounds/Communications”. In the upper portion of the “Sounds” tab window is the drop down selection for “Sound Scheme”. There I select “No sounds”. Maybe its a sound card/interface thing, I use UR22mk2 on one of the Win 7 systems.

I would be interested in knowing your tweaks for Win 10, (PM?) your mention of Win NT made me smile, I was using my NT system about a month ago, the ISA based audio card (CardD+) can digitize audio down to DC.

No. I tried again – With Aero selected I have Windows default sounds and No Screensaver. Unlike without Aero, I cannot change these.