Dorico 2 Pro - cannot get video import to work

IIRC, the video will only be as long the flow it is attached to. Try adding a few more beats or measures

Yeah I tried that already multiple times, added 50 bars to the flow, no difference.

Are you in the right mode (Play mode) ?

I may be preaching to the choir here, but do read the instructions in the Version History here if you haven’t already:

I’ve been attaching it in Setup Mode directly onto the Flow itself, the video dialogue even comes up to let me set the framrate, timing offsets etc so I don’t think that’s the issue here.

Right now I’m considering just reinstalling Dorico from scratch and seeing if that resolves the problem.

Videos are attached in Setup mode, not Play mode.

That just looks totally wrong. Are you able to open the Video Properties window? What’s in there?

Maybe the install is screwed up, uninstall/reinstall doesn’t take much time, have you checked that?

Edit- we typed at the same time, lemme know how it goes. I’m using video in Dorico as we speak. What are you using to convert the video? I can share settings if you like.

Here’re the settings I used in Resolve for a video that attaches properly, and plays back, etc. (the audio is 48k PCM) Note the frame rate for the video and audio is constant, not variable. (but really, the reinstall seems a more likely fix.)

Steve, I’ve never touched video in Dorico, but I did read and comprehend the documentation.

I’d like to suggest you do the same, preferably before shouting users down.

Dorico 2 Version History, Page 4.

“In Play mode, drag the video file from the folder where it is located and drop it on the timeline at the position where you want the video to be attached.”

Hi Steve,

Yes reinstalling is the option i’m seriously considering right now. I’m using a progam I’ve used for years called Pavtube HD Video Convertor for this and it’s served me well before with getting videos into the correct format for Sibelius and Cubase. I also attempted re-rendering the video from inside Sony Vegas 14 to see if I had any more luck there.

I can certainly get the video properties box up and that’s looks fine to my eyes (aside from the fps discrepancy):

I do have Dorico installed on my main machine as well so I’ll see if I get the same behaviour there.

Ok, so after some testing I think I definitely need to reinstall Dorico 2 on my laptop as I managed to attach the video without issue on my desktop machine:

The exact same video file gave me the result I described before on the laptop Dorico installation. I’ll report back on how this goes.

Ok reinstalling didn’t seem to solve the issue, but then I didn’t trash my preferences or anything like that either… my previous files still showed up in the hub for instance. I’m wondering if I have to hose my system completely of the program before it’ll work.

Ok so it looks like I’ve got it working again, although I’ll have to redo all my preferences probably, or import them from my desktop setup.

Just in case anybody else comes across the same issue I basically uninstalled Dorico then deleted any related folders in the following locations (Windows 10):

C:\Program Files\Steinberg\Dorico 2
C:\Users<username\AppData\Roaming\Steinberg\Dorico 2

I also cleaned up the registry a bit.

The video import is now running perfectly for me. :slight_smile:

Great news.

I’m sorry to say the problem keeps reoccurring for no good reason. I’ll be working away just fine on a score with the same video for some time then suddenly when I decide to reopen my score in Dorico later on to do more work the video decides to stop working again… and no amount of restarting or rebooting the PC resolves it.

I’m getting a bit tired of having to fully uninstall Dorico, clear all the my preferences and any files then reinstall it all again just to get working video in my projects, there must be good reason this keeps happening (maybe a bug in video playback system) but I haven’t figured it out yet.

Trying a different approach after doing a bit of research on Cubase video issues (as I imagine they use the same engine), I’m now busy converting the video to ProRes format using this tool:

I’ll report back on whether this works or not (without reinstalling Dorico).

OK, so that didn’t work. I’m really starting to think it’s actually a random bug with the video engine in Dorico rather than anything I’m doing wrong as far as conversion goes, the same video file opens and plays perfectly in Cubase Artist 9.0.30. Ironically the last time I posted about this here the issue was on my laptop, this time it’s on my main PC. :wink:

I don’t know if it’s of any help as far as possible bug testing goes but i decided to go poking around in the files for both Cubase and Dorico and noted that videoengine.dll for each is slightly different:

Whether this has a bearing on my issue I don’t know, I’m not a programmer by trade, but I thought it was interesting nonetheless.

So I guess I’m going to have to do what I did last time; uninstall Dorico, trash all my preferences and start over again. This is only annoying because when everything is working as it should it’s pretty much flawless, synchronisation is rock solid and navigating through the video using the shortcuts is quick and painless… just generally writing to film in Dorico is a joy. Hopefully whatever is going on here can be resolved eventually.

I read through your posts about this, and I don’t see anywhere that you tried re-attaching (aka re-importing) the video file. Have you done this?

Yes I tried multiple times in both the original project I was working on and in a completely fresh solo piano template from the default menu to make sure, it’s the same issue every time. Currently reinstalling…

Interestingly now I’ve reinstalled the ProRes video is showing up in the project but I only have audio, I’ll try re-encoding to Avid DNxHD and see if that works any better.

Well I don’t have a license for that codec but it certainly let me know that in the video window itself in Dorico, so I presume it would work in that case.

I’ll try the H264 codec in the conversion tool I mentioned as a last resort before I go back to what I was using before the issue started.

When it fails, perhaps send the log so they can check.
Perhaps try another video converter (or try any video file from another source).

I tried converting the original file again to the H264 codec in a .mov container using the same utility and now it’s working fine, however it remains to be seen just how long it will keep working for this time… I’m not entirely convinced about the stability of the Dorico video playback engine yet.

Sorry you’re having these kinds of problems, Terry. Would it be possible for you to share the original file with us, for the purposes of troubleshooting? If so, please send it to me via WeTransfer (to d dot spreadbury at steinberg dot de) so I can ask the video engine team if they have any ideas.

Ah well, this is the thing, it’s all working again now so I’m not sure me sending you the Dorico file will help that much as I replaced the original video with a newly encoded version. however I can if you like. It does use quite a few third party plugins (Kontakt and Engine mainly) and Noteperformer 3 as well though.

The file for the previous cue I was working on (which had similar issues to begin with) does still have the filename for the original video attached although the file itself has since been deleted, I could send that instead.